<!DOCTYPE html>
<html lang="fr-FR">
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, user-scalable=no, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0">
<title>Présentation de l’attaque Man In The Contacts pour piéger les utilisateurs de WhatsApp, Signal et Telegram &#8211; Partie 2/2 | Le blog de MISC</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://www.miscmag.com/xmlrpc.php" />

<link rel="apple-touch-icon" sizes="57x57" href="/apple-touch-icon-57x57.png">
<link rel="apple-touch-icon" sizes="114x114" href="/apple-touch-icon-114x114.png">
<link rel="apple-touch-icon" sizes="72x72" href="/apple-touch-icon-72x72.png">
<link rel="apple-touch-icon" sizes="144x144" href="/apple-touch-icon-144x144.png">
<link rel="apple-touch-icon" sizes="60x60" href="/apple-touch-icon-60x60.png">
<link rel="apple-touch-icon" sizes="120x120" href="/apple-touch-icon-120x120.png">
<link rel="apple-touch-icon" sizes="76x76" href="/apple-touch-icon-76x76.png">
<link rel="apple-touch-icon" sizes="152x152" href="/apple-touch-icon-152x152.png">
<link rel="icon" type="image/png" href="/favicon-196x196.png" sizes="196x196">
<link rel="icon" type="image/png" href="/favicon-160x160.png" sizes="160x160">
<link rel="icon" type="image/png" href="/favicon-96x96.png" sizes="96x96">
<link rel="icon" type="image/png" href="/favicon-16x16.png" sizes="16x16">
<link rel="icon" type="image/png" href="/favicon-32x32.png" sizes="32x32">
<meta name="msapplication-TileColor" content="#ee6f08">
<meta name="msapplication-TileImage" content="/mstile-144x144.png">

<!--[if lt IE 9]>
<script src="https://www.miscmag.com/wp-content/themes/mon-cahierMISC/js/html5.js" type="text/javascript"></script>
<![endif]-->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Le blog de MISC &raquo; Flux" href="https://www.miscmag.com/?feed=rss2" />
<link rel="alternate" type="application/rss+xml" title="Le blog de MISC &raquo; Flux des commentaires" href="https://www.miscmag.com/?feed=comments-rss2" />
<link rel="alternate" type="application/rss+xml" title="Le blog de MISC &raquo; Présentation de l’attaque Man In The Contacts pour piéger les utilisateurs de WhatsApp, Signal et Telegram &#8211; Partie 2/2 Flux des commentaires" href="https://www.miscmag.com/?feed=rss2&#038;p=716" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.miscmag.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.2"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='crayon-css'  href='https://www.miscmag.com/wp-content/plugins/crayon-syntax-highlighter/css/min/crayon.min.css?ver=_2.7.2_beta' type='text/css' media='all' />
<link rel='stylesheet' id='gglcptch-css'  href='https://www.miscmag.com/wp-content/plugins/google-captcha/css/gglcptch.css?ver=1.32' type='text/css' media='all' />
<link rel='stylesheet' id='style-css'  href='https://www.miscmag.com/wp-content/themes/mon-cahierMISC/style.css?ver=4.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='googleFonts-css'  href='http://fonts.googleapis.com/css?family=Cutive%7CReenie+Beanie&#038;ver=4.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='dvk-social-sharing-css'  href='https://www.miscmag.com/wp-content/plugins/dvk-social-sharing/assets/css/styles.min.css?ver=1.3' type='text/css' media='all' />
<link rel='stylesheet' id='fancybox-css'  href='https://www.miscmag.com/wp-content/plugins/easy-fancybox/fancybox/jquery.fancybox-1.3.8.min.css?ver=1.6' type='text/css' media='screen' />
<script type='text/javascript' src='https://www.miscmag.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.miscmag.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var CrayonSyntaxSettings = {"version":"_2.7.2_beta","is_admin":"0","ajaxurl":"https:\/\/www.miscmag.com\/wp-admin\/admin-ajax.php","prefix":"crayon-","setting":"crayon-setting","selected":"crayon-setting-selected","changed":"crayon-setting-changed","special":"crayon-setting-special","orig_value":"data-orig-value","debug":""};
var CrayonSyntaxStrings = {"copy":"Faites %s pour copier, %s pour coller","minimize":"Click To Expand Code"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.miscmag.com/wp-content/plugins/crayon-syntax-highlighter/js/min/crayon.min.js?ver=_2.7.2_beta'></script>
<link rel='https://api.w.org/' href='https://www.miscmag.com/index.php?rest_route=/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.miscmag.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.miscmag.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Présentation de l’attaque Man In The Contacts pour piéger les utilisateurs de WhatsApp, Signal et Telegram &#8211; Partie 1/2' href='https://www.miscmag.com/?p=708' />
<meta name="generator" content="WordPress 4.8.2" />
<link rel="canonical" href="https://www.miscmag.com/?p=716" />
<link rel='shortlink' href='https://www.miscmag.com/?p=716' />
<link rel="alternate" type="application/json+oembed" href="https://www.miscmag.com/index.php?rest_route=%2Foembed%2F1.0%2Fembed&#038;url=https%3A%2F%2Fwww.miscmag.com%2F%3Fp%3D716" />
<link rel="alternate" type="text/xml+oembed" href="https://www.miscmag.com/index.php?rest_route=%2Foembed%2F1.0%2Fembed&#038;url=https%3A%2F%2Fwww.miscmag.com%2F%3Fp%3D716&#038;format=xml" />
		<style>
			a {color: }
			a:hover {color: }
		</style>		
	<style type="text/css" id="custom-background-css">
body.custom-background { background-image: url("https://www.miscmag.com/wp-content/uploads/2017/01/Fotolia_107632854_Subscription_XXL-v2.jpg"); background-position: center center; background-size: cover; background-repeat: repeat; background-attachment: fixed; }
</style>

<!-- Easy FancyBox 1.6 using FancyBox 1.3.8 - RavanH (http://status301.net/wordpress-plugins/easy-fancybox/) -->
<script type="text/javascript">
/* <![CDATA[ */
var fb_timeout = null;
var fb_opts = { 'overlayShow' : true, 'hideOnOverlayClick' : true, 'showCloseButton' : true, 'margin' : 20, 'centerOnScroll' : true, 'enableEscapeButton' : true, 'autoScale' : true };
var easy_fancybox_handler = function(){
	/* IMG */
	var fb_IMG_select = 'a[href*=".jpg"]:not(.nolightbox,li.nolightbox>a), area[href*=".jpg"]:not(.nolightbox), a[href*=".jpeg"]:not(.nolightbox,li.nolightbox>a), area[href*=".jpeg"]:not(.nolightbox), a[href*=".png"]:not(.nolightbox,li.nolightbox>a), area[href*=".png"]:not(.nolightbox), a[href*=".webp"]:not(.nolightbox,li.nolightbox>a), area[href*=".webp"]:not(.nolightbox)';
	jQuery(fb_IMG_select).addClass('fancybox image');
	var fb_IMG_sections = jQuery('div.gallery ');
	fb_IMG_sections.each(function() { jQuery(this).find(fb_IMG_select).attr('rel', 'gallery-' + fb_IMG_sections.index(this)); });
	jQuery('a.fancybox, area.fancybox, li.fancybox a').fancybox( jQuery.extend({}, fb_opts, { 'transitionIn' : 'elastic', 'easingIn' : 'easeOutBack', 'transitionOut' : 'elastic', 'easingOut' : 'easeInBack', 'opacity' : false, 'hideOnContentClick' : false, 'titleShow' : true, 'titlePosition' : 'over', 'titleFromAlt' : true, 'showNavArrows' : true, 'enableKeyboardNav' : true, 'cyclic' : false }) );
}
var easy_fancybox_auto = function(){
	/* Auto-click */
	setTimeout(function(){jQuery('#fancybox-auto').trigger('click')},1000);
}
/* ]]> */
</script>
</head>

<body class="post-template-default single single-post postid-716 single-format-standard custom-background">




<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-22350734-12', 'auto');
  ga('require', 'displayfeatures');
  ga('send', 'pageview');

</script>

<div id="page" class="hfeed site">
		<header id="masthead" class="site-header" role="banner">
<!--		<hgroup class="site-intro">
			<h1 class="site-title"><a href="https://www.miscmag.com/" title="Le blog de MISC" rel="home">Le blog de MISC</a></h1>
			<h2 class="site-description">100% sécurité informatique</h2>
		</hgroup> -->
		
		<!-- if there's a header image, let's display it here -->

		
			<a href="https://www.miscmag.com/" title="Le blog de MISC" rel="home"><img src="https://www.miscmag.com/wp-content/uploads/2017/01/blog_misc_bannier-2017.jpg" width="988" height="200" alt="" /></a>

		
		<nav role="navigation" class="site-navigation main-navigation">
			<h1 class="assistive-text">Menu &#9776</h1>
			<div class="assistive-text skip-link"><a href="#content" title="Passer directement au contenu">Passer directement au contenu</a></div>
			<div class="menu"><ul id="menu-menu-principal" class="menu"><li id="menu-item-13" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-13"><a href="http://www.miscmag.com/">Accueil</a></li>
<li id="menu-item-14" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-14"><a href="http://www.miscmag.com/">Le magazine</a>
<ul  class="sub-menu">
	<li id="menu-item-19" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19"><a target="_blank" href="https://boutique.ed-diamond.com/23-anciens-numeros#/titre-misc">Derniers numéros</a></li>
	<li id="menu-item-20" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-20"><a target="_blank" href="https://boutique.ed-diamond.com/abonnements/7-misc">S&rsquo;abonner</a></li>
	<li id="menu-item-268" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-268"><a href="http://www.editions-diamond.fr/devenir-auteur/">Devenir auteur</a></li>
</ul>
</li>
<li id="menu-item-15" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-15"><a href="http://www.miscmag.com/">Nos autres magazines</a>
<ul  class="sub-menu">
	<li id="menu-item-21" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-21"><a target="_blank" href="https://boutique.ed-diamond.com/content/22-en-savoir-plus-sur-gnulinux-magazine">GNU/Linux Magazine</a></li>
	<li id="menu-item-22" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22"><a target="_blank" href="https://boutique.ed-diamond.com/content/25-en-savoir-plus-sur-linux-pratique">Linux Pratique</a></li>
	<li id="menu-item-24" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24"><a target="_blank" href="https://boutique.ed-diamond.com/content/23-en-savoir-plus-sur-hackable-magazine">Hackable</a></li>
</ul>
</li>
<li id="menu-item-559" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-559"><a href="http://www.miscmag.com/">Lecture en ligne</a>
<ul  class="sub-menu">
	<li id="menu-item-560" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-560"><a target="_blank" href="http://connect.ed-diamond.com/MISC">Découvrir Connect</a></li>
	<li id="menu-item-561" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-561"><a target="_blank" href="https://boutique.ed-diamond.com/27-base-documentaire">Abonnements particuliers à Connect</a></li>
	<li id="menu-item-573" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-573"><a target="_blank" href="https://proboutique.ed-diamond.com/abo-pro-basedoc">Abonnements professionnels à Connect</a></li>
</ul>
</li>
<li id="menu-item-18" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-18"><a href="http://www.miscmag.com/">La boutique</a>
<ul  class="sub-menu">
	<li id="menu-item-563" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-563"><a target="_blank" href="https://boutique.ed-diamond.com/">Particuliers</a></li>
	<li id="menu-item-564" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-564"><a target="_blank" href="https://proboutique.ed-diamond.com/">Professionnels</a></li>
</ul>
</li>
<li id="menu-item-17" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17"><a href="https://www.miscmag.com/?page_id=9">À propos</a></li>
</ul></div>		</nav>
		
	 
	 <ul class="social-media">
							<li><a href="https://twitter.com/MISCRedac" class="twitter">Twitter</a></li>
			
						
						
						
						
						
			
						
						
						
						
						
			
							<li><a href="https://www.miscmag.com/?feed=rss2" class="rss">Flux RSS</a></li>
					</ul><!-- #social-icons-->
				
	</header><!-- #masthead .site-header -->

<aside id="widget_sp_image-12" class="widget_sp_image"><div align="center"><a href="http://connect.ed-diamond.com/MISC" target="_blank" class="widget_sp_image-image-link"><img width="960" height="150" class="attachment-full" style="max-width: 100%;" srcset="https://www.miscmag.com/wp-content/uploads/2017/03/banner-blogsMags-Connect-1MISC.jpg 960w, https://www.miscmag.com/wp-content/uploads/2017/03/banner-blogsMags-Connect-1MISC-300x47.jpg 300w, https://www.miscmag.com/wp-content/uploads/2017/03/banner-blogsMags-Connect-1MISC-768x120.jpg 768w" sizes="(max-width: 960px) 100vw, 960px" src="https://www.miscmag.com/wp-content/uploads/2017/03/banner-blogsMags-Connect-1MISC.jpg" /></a></div></aside>
	<div id="main">
		<div id="primary" class="site-content">
			<div id="content" role="main">

			
				
<article id="post-716" class="post-716 post type-post status-publish format-standard hentry category-article tag-chiffrement-de-bout-en-bout tag-contacts tag-man-in-the-middle tag-messageries-securisees tag-mobile">
	<header class="entry-header">
		
					<h1 class="entry-title">Présentation de l’attaque Man In The Contacts pour piéger les utilisateurs de WhatsApp, Signal et Telegram &#8211; Partie 2/2</h1>
				
		<div class="entrymeta">
			<time class="entry-date updated" datetime="2017-10-18T09:00:06+00:00" pubdate>18 octobre 2017</time><span class="byline"> par <span class="author vcard"><a class="url fn n" href="https://www.miscmag.com/?author=622" title="Voir tous les articles par redaction" rel="author">redaction</a></span></span>		</div><!-- .entry-meta -->
	</header><!-- .entry-header -->

	<div class="entry-content">
		<h1><a href="https://www.miscmag.com/wp-content/uploads/2017/01/cc.png"><img class="alignnone size-full wp-image-503" src="https://www.miscmag.com/wp-content/uploads/2017/01/cc.png" alt="" width="80" height="15" /></a></h1>
<h1>4. Le fond du problème</h1>
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Nous venons de montrer qu’il est relativement aisé de monter une attaque de type homme du milieu via les contacts et une application complice. Et cela en n’exploitant aucune faille de type 0-day dans le système d’exploitation !</span></p>
<p><span id="more-716"></span></p>
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">La conversation est toujours parfaitement chiffrée de bout en bout, mais il n’est simplement pas évident de savoir avec qui l’on dialogue vraiment. La problématique de l’authentification de l’interlocuteur est totalement négligée (cf. deuxième hypothèse du paragraphe 1), alors qu’elle est fondamentale pour qui veut avoir un échange de messages sécurisé.</span></p>
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">On accorde une confiance bien trop grande aux informations stockées dans le carnet d’adresses, alors qu’elles devraient être fournies ou au moins validées explicitement par l’utilisateur pour rester sous son contrôle.</span></p>
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Le principe du <i>Trust On First Use</i> (TOFU) est utilisé pour accepter automatiquement une nouvelle clé lors du dialogue avec un nouveau contact, alors qu’il s’agit d’un évènement rare nécessitant un regain de vigilance. Le message de WhatsApp expliquant à ce moment-là qu’une conversation sécurisée démarre est très maladroit de ce point de vue.</span></p>
<h1 class="western">5. Évaluation du risque</h1>
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Avant d’aller plus loin, procédons à une rapide évaluation du risque pour être bien d’accord sur la gravité de la situation.</span></p>
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Nous utiliserons une méthodologie élémentaire de calcul du risque selon le tableau ci-dessous. Nous considérons que le risque est le produit de la difficulté de l’attaque par son impact sur les utilisateurs.</span></p>
<table width="100%" cellspacing="0" cellpadding="4">
<colgroup>
<col width="64*" />
<col width="64*" />
<col width="64*" />
<col width="64*" /> </colgroup>
<tbody>
<tr valign="top">
<td width="25%"><span style="font-family: Verdana, Geneva; font-size: 14px;"><b>Difficulté de l’attaque</b></span></td>
<td width="25%"><span style="font-family: Verdana, Geneva; font-size: 14px;"><b>Faible impact utilisateur</b></span></td>
<td width="25%"><span style="font-family: Verdana, Geneva; font-size: 14px;"><b>Impact utilisateur modéré</b></span></td>
<td width="25%"><span style="font-family: Verdana, Geneva; font-size: 14px;"><b>Fort impact utilisateur</b></span></td>
</tr>
<tr valign="top">
<td width="25%"><span style="font-family: Verdana, Geneva; font-size: 14px;">Faible</span></td>
<td width="25%"><span style="font-family: Verdana, Geneva; font-size: 14px;">Faible</span></td>
<td width="25%"><span style="font-family: Verdana, Geneva; font-size: 14px;">Modéré</span></td>
<td width="25%"><span style="font-family: Verdana, Geneva; font-size: 14px;">Très élevé</span></td>
</tr>
<tr valign="top">
<td width="25%"><span style="font-family: Verdana, Geneva; font-size: 14px;">Moyenne</span></td>
<td width="25%"><span style="font-family: Verdana, Geneva; font-size: 14px;">Faible</span></td>
<td width="25%"><span style="font-family: Verdana, Geneva; font-size: 14px;">Modéré</span></td>
<td width="25%"><span style="font-family: Verdana, Geneva; font-size: 14px;">Élevé</span></td>
</tr>
<tr valign="top">
<td width="25%"><span style="font-family: Verdana, Geneva; font-size: 14px;">Élevée</span></td>
<td width="25%"><span style="font-family: Verdana, Geneva; font-size: 14px;">Faible</span></td>
<td width="25%"><span style="font-family: Verdana, Geneva; font-size: 14px;">Faible</span></td>
<td width="25%"><span style="font-family: Verdana, Geneva; font-size: 14px;">Modéré</span></td>
</tr>
</tbody>
</table>
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">La difficulté de l’attaque peut s’évaluer à travers 2 dimensions :</span></p>
<ul>
<li><span style="font-family: Verdana, Geneva; font-size: 14px;"><span style="font-family: Verdana, Geneva; font-size: 14px;">Difficulté technique : Faible<br />
L’implémentation de l’application Pierre – Feuille – Ciseau est aisée : il suffit de modifier les contacts à travers l’API disponible et de faire des appels type web service vers un serveur.<br />
L’application sera acceptée sans souci pour publication puisque le code malveillant est stocké sur le serveur de l’attaquant.</span></span></li>
<li><span style="font-family: Verdana, Geneva; font-size: 14px;">Difficulté logistique : Moyenne<br />
Un seul numéro de téléphone suffit à Ève pour intercepter des milliers de conversations.<br />
Mais il faut convaincre suffisamment de personnes d’installer l’application Pierre / Feuille / Ciseau. L’accès au carnet d’adresses permet d’accélérer l’adoption en faisant automatiquement la promotion du jeu auprès de tous les contacts. </span></li>
</ul>
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">L’impact utilisateur s’estime plus simplement comme Fort.<br />
En effet, des milliers d’utilisateurs peuvent être espionnés à travers les trois applications de messageries, ce qui brise la promesse d’échanges sécurisés. De plus, à cause des identifiants qu’elles laissent traîner dans le carnet d’adresses, il est possible de savoir quelles applications de messagerie sont installées.</span></p>
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">En croisant un fort impact et une difficulté faible à moyenne, nous obtenons un risque élevé à très élevé.</span></p>
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">De nombreuses attaques similaires sont imaginables, notamment en ciblant les spécificités d’implémentation de chaque application de messagerie. Des utilisations abusives à des fins de <i>spear phishing</i> sont envisageables, mais aussi de spam étant donné que les serveurs de messagerie ne peuvent plus filtrer le contenu des messages puisqu’ils sont indéchiffrables pour eux. </span></p>
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Nous nommerons désormais <i>Man In The Contacts</i> cette famille d’attaque exploitant l’accès aux contacts des applications mobiles.</span></p>
<h1 class="western">6. La responsabilité des éditeurs</h1>
<h2 class="western">6.1 Pourquoi devraient-ils adresser ce point ?</h2>
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Bien qu’il ne s’agisse pas d’une vulnérabilité purement technique, le risque est malgré tout réel pour les utilisateurs finaux. À aucun moment nous ne pouvons considérer qu’ils ont une mauvaise hygiène sécurité : l’application est téléchargée depuis le magasin officiel et a été approuvée, les mises à jour sont effectuées régulièrement.</span></p>
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">À première vue, le système d’exploitation mobile est responsable de la faible segmentation de l’accès aux données de contact. Mais ce n’est pas une raison pour ne pas adresser cette faiblesse. Le principe même du reste de l’application est de construire une solution sécurisée sur des bases avérées fragiles (réseaux hostiles, serveurs perquisitionnés, etc.). Il serait étonnant de ne pas vouloir se soucier de l’authentification des utilisateurs.</span></p>
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Ce protocole cryptographique d’une grande rigueur a été mis en place suite aux révélations de Snowden. Il permet notamment de se dédouaner de toute demande d’accès par les autorités. On pourrait s’interroger, en constatant que l’application mobile est implémentée avec une plus grande légèreté (cf. hypothèse 2 du paragraphe 1), s’il ne s’agit pas là de la motivation principale, en complément d’un argumentaire marketing rassurant.</span></p>
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Dans tous les cas, la confiance de l’utilisateur devrait être respectée. En effet, on lui promet explicitement que sa conversation est sécurisée de bout en bout. Peu importe les limitations de la plateforme, des solutions doivent être trouvées pour tendre vers cet objectif.</span></p>
<h2 class="western">6.2 Le retour des éditeurs</h2>
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Il n’a pas été aisé d’obtenir un retour des éditeurs. Les programmes de Bug Bounty se généralisent, mais ni WhatsApp, ni Telegram, ni Signal n’en faisaient partie en 2016.</span></p>
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Telegram dispose d’un très réactif support de premier niveau à travers son application mobile. Une adresse mail sécurité a été fournie et le descriptif de l’attaque détaillée au paragraphe 3.3 y a été envoyé. Malgré 3 relances et une publication sur Twitter, aucune réponse n’a jamais été reçue.</span></p>
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">WhatsApp dispose du programme de remontée de bugs de sa maison mère, Facebook. Malgré un acquittement rapide, une relance a dû être nécessaire pour obtenir la réponse ci-dessous (traduite de l’anglais) :<br />
« Nous apprécions votre rapport. Au final un attaquant avec un malware installé sur son périphérique sera capable d’altérer les données du périphérique lui-même. Dans vos exemples les conversations WhatsApp sont restées correctement liées à leurs numéros de téléphone. De plus, WhatsApp autorise les utilisateurs à définir des alias locaux pour les contacts et à voir le numéro associé à un message spécifique à n’importe quel moment. Cela étant, nous ne considérons pas que ce comportement pose un risque significatif et nous ne prévoyons pas de faire de changement. Veuillez nous informer si vous pensez que nous avons mal interprété quelque chose ! »<br />
Il n’a pas été possible de continuer la conversation, malgré la proposition en dernière ligne.</span></p>
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Signal ne disposant pas d’un processus connu de déclaration d’incident, un rapport de bug dans l’application Android a été soumis, mais non suivi d’effets malgré plusieurs relances. Une publication sur Twitter et un peu d’insistance ont permis d’obtenir successivement le message suivant (traduit de l’anglais) :<br />
« Comme pour toutes les techniques d’interception, les numéros de sécurité ont été conçus pour cela. Les utilisateurs de Signal seront notifiés que les numéros de sécurité pour leurs contacts ont changé, et seront amenés à les vérifier. Une attaque d’homme du milieu réussie nécessiterait de trouver une méthode pour intercepter les communications sans déclencher cet avertissement ».</span></p>
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Après avoir fait remarquer que les numéros de sécurité ne s’appliquent pas à une nouvelle conversation avec un nouveau contact, cette brève réponse a été obtenue :<br />
« Signal n’a pas été conçu pour se protéger des malwares. Merci d’être entré en contact, bonne chance avec tout le reste ».</span></p>
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Il est évident qu’il ne s’agit pas d’une vulnérabilité nécessitant seulement la modification de quelques lignes de code, mais au contraire qui exige de repenser l’expérience utilisateur. Cependant un peu plus de considération était attendue, en tenant compte de ce qui a été discuté au paragraphe 6.1</span></p>
<h1 class="western">7. Contremesures</h1>
<h2 class="western">7.1 Utilisateur final</h2>
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Il s’agira tout d’abord de réduire au maximum le nombre d’applications ayant accès aux contacts, surtout en écriture. Mais en pratique cela n’est guère évident, notamment sur les versions les plus répandues d’Android qui ne demandent les permissions qu’au moment de l’installation.</span></p>
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Ensuite il faut être vigilant quand une nouvelle conversation débute. En cas de suspicion, ne pas hésiter à jeter un coup d’œil dans ses contacts.</span></p>
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Enfin, d’autres applications de messagerie sécurisée existent, comme Threema <b>[8]</b>. Avec un authentifiant décorrélé du numéro de téléphone et une synchronisation optionnelle des contacts, cette solution est bien plus robuste d’un point de vue conception. D’autant plus qu’une réponse technique claire et détaillée a été fournie sous 24 heures par le service de presse.</span></p>
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Un niveau de confiance vert/orange/rouge affiché est aussi clairement affiché à côté du nom de l’interlocuteur, l’utilisateur se rendant aisément compte d’une situation anormale.</span></p>
<h2 class="western">7.2 Applications de messagerie mobile</h2>
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Un identifiant dédié, indépendant du numéro de téléphone, devrait être utilisé. Et une approbation explicite de chaque ajout de contact demandée à l’utilisateur.<br />
Ou a minima gérer le risque en avertissant l’utilisateur lorsqu’il s’agit du tout premier échange avec un nouveau contact.</span></p>
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Afficher le numéro de téléphone peut également aider, même si seulement une minorité des numéros sont connus par cœur par l’utilisateur.</span></p>
<h2 class="western">7.3 Systèmes d’exploitation mobile</h2>
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">L’amélioration la plus souhaitable serait de mettre en œuvre un véritable partitionnement des informations de contact, comme c’est le cas pour les accès aux fichiers, pour être capable de gérer une notion de données privées.</span></p>
<p align="right"><span style="font-family: Verdana, Geneva; font-size: 14px;"><b>Jérémy Matos<br />
</b></span><span style="font-family: Verdana, Geneva; font-size: 14px;">Expert en sécurité applicative chez Securing Apps – jeremy.matos@securingapps.com</span></p>
<h1 class="western">Remerciements</h1>
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Je tiens à remercier grandement Olivier Saudan et Jean-Philippe Aumasson pour leurs précieux conseils lors de la rédaction de cet article.</span></p>
<h1 class="western">Références</h1>
<p><span style="font-family: Verdana, Geneva; font-size: small;"><b>[1]</b> Recommandations sécurité d&rsquo;Edward Snowden : <a href="https://twitter.com/snowden/status/778592275144314884" target="_blank" rel="noopener">https://twitter.com/snowden/status/778592275144314884</a><b><br />
</b></span><span style="font-family: Verdana, Geneva; font-size: small;"><b>[2]</b> Discours de Bernard Cazeneuve sur le terrorisme et le chiffrement : <a href="http://www.lemonde.fr/pixels/article/2016/08/23/terrorisme-pour-contourner-le-chiffrement-des-messages-bernard-cazeneuve-en-appelle-a-l-europe_4986897_4408996.html" target="_blank" rel="noopener">http://www.lemonde.fr/pixels/article/2016/08/23/terrorisme-pour-contourner-le-chiffrement-des-messages-bernard-cazeneuve-en-appelle-a-l-europe_4986897_4408996.html</a><b><br />
</b></span><span style="font-family: Verdana, Geneva; font-size: small;"><b>[3]</b> A Formal Security Analysis of the Signal Messaging Protocol : <a href="https://eprint.iacr.org/2016/1013.pdf" target="_blank" rel="noopener">https://eprint.iacr.org/2016/1013.pdf</a><b><br />
</b></span><span style="font-family: Verdana, Geneva; font-size: small;"><b>[4]</b> Anciens mots de passe WhatsApp prévisibles : <a href="http://thednetworks.com/2012/09/09/whatsapp-imei-password-md5-inverted-hack/" target="_blank" rel="noopener">http://thednetworks.com/2012/09/09/whatsapp-imei-password-md5-inverted-hack/</a><b><br />
</b></span><span style="font-family: Verdana, Geneva; font-size: small;"><b>[5]</b> Intrusion Telegram en Iran : <a href="https://www.wired.com/2016/08/hack-brief-hackers-breach-ultra-secure-messaging-app-telegram-iran/" target="_blank" rel="noopener">https://www.wired.com/2016/08/hack-brief-hackers-breach-ultra-secure-messaging-app-telegram-iran/</a><b><br />
</b></span><span style="font-family: Verdana, Geneva; font-size: small;"><b>[6]</b> Présentation Man In The Contacts : <a href="http://www.securingapps.com/blog/ManInTheContacts_CYBSEC16.pdf" target="_blank" rel="noopener">http://www.securingapps.com/blog/ManInTheContacts_CYBSEC16.pdf</a><b><br />
</b></span><span style="font-family: Verdana, Geneva; font-size: small;"><b>[7]</b> Unicode URL Hack : <a href="https://www.schneier.com/blog/archives/2005/02/unicode_url_hac_1.html" target="_blank" rel="noopener">https://www.schneier.com/blog/archives/2005/02/unicode_url_hac_1.html</a><b><br />
</b></span><span style="font-family: Verdana, Geneva; font-size: small;"><b>[</b><b>8</b><b>] </b>Application de messagerie sécurisée Threema : <a href="https://threema.ch/en" target="_blank" rel="noopener">https://threema.ch/en</a></span></p>
<p style="text-align: center;"><span style="background-color: #99cc00; color: #ffffff;"><strong>Retrouvez cet article (et bien d&rsquo;autres) dans <em>MISC n°90</em>, disponible sur <a href="https://boutique.ed-diamond.com/home/1223-misc-90.html?search_query=misc90&amp;results=1" target="_blank" rel="noopener"><span style="text-decoration: underline;"><span style="color: #ffffff; text-decoration: underline;">la boutique</span></span></a> et </strong><span style="text-decoration: underline;"><a href="http://connect.ed-diamond.com/" target="_blank" rel="noopener"><strong><span style="color: #ffffff; text-decoration: underline;">sur la plateforme de lecture en ligne Connect !</span></strong></a></span></span></p>
<p>&nbsp;</p>
	<!-- Social Sharing by Danny - v1.3 - https://wordpress.org/plugins/dvk-social-sharing/ -->
	<p class="dvk-social-sharing ss-icon-size-32">
        			<span class="ss-ask">Partager :</span>
		
        <a rel="external nofollow" class="ss-twitter" href="https://twitter.com/intent/tweet/?text=Pr%C3%A9sentation+de+l%E2%80%99attaque+Man+In+The+Contacts+pour+pi%C3%A9ger+les+utilisateurs+de+WhatsApp%2C+Signal+et+Telegram+%E2%80%93+Partie+2%2F2&url=https%3A%2F%2Fwww.miscmag.com%2F%3Fp%3D716" target="_blank">
					<span class="ss-icon ss-icon-twitter"></span>
					<span class="ss-text">sur Twitter</span>
					</a> <a rel="external nofollow" class="ss-facebook" href="https://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fwww.miscmag.com%2F%3Fp%3D716&p[title]=Pr%C3%A9sentation+de+l%E2%80%99attaque+Man+In+The+Contacts+pour+pi%C3%A9ger+les+utilisateurs+de+WhatsApp%2C+Signal+et+Telegram+%E2%80%93+Partie+2%2F2" target="_blank" >
						<span class="ss-icon ss-icon-facebook"></span>
						<span class="ss-text">sur Facebook</span>
					</a> <a rel="external nofollow" class="ss-googleplus" href="https://plus.google.com/share?url=https%3A%2F%2Fwww.miscmag.com%2F%3Fp%3D716" target="_blank" >
						<span class="ss-icon ss-icon-googleplus"></span>
						<span class="ss-text">sur Google+</span>
					</a>     </p>
    <!-- / Social Sharing By Danny -->
   			</div><!-- .entry-content -->
	<footer class="entry-meta">
		<p>
						<span class="cat-links">
				Publié dans :  <a href="https://www.miscmag.com/?cat=52" rel="category">article</a>			</span>
			<span class="sep"> | </span>
			
						<span class="tag-links">
				Étiqueté : <a href="https://www.miscmag.com/?tag=chiffrement-de-bout-en-bout" rel="tag">chiffrement de bout en bout</a>, <a href="https://www.miscmag.com/?tag=contacts" rel="tag">contacts</a>, <a href="https://www.miscmag.com/?tag=man-in-the-middle" rel="tag">Man In The Middle</a>, <a href="https://www.miscmag.com/?tag=messageries-securisees" rel="tag">messageries sécurisées</a>, <a href="https://www.miscmag.com/?tag=mobile" rel="tag">Mobile</a>			</span>
			
				</p>
	</footer><!-- #entry-meta -->

</article><!-- #post-716 -->
					<nav role="navigation" id="nav-below" class="site-navigation post-navigation">
		<h1 class="assistive-text">Parcourir les articles</h1>

	
		<div class="nav-previous"><a href="https://www.miscmag.com/?p=708" rel="prev"><span class="meta-nav">&larr;</span> Présentation de l’attaque Man In The Contacts pour piéger les utilisateurs de WhatsApp, Signal et Telegram &#8211; Partie 1/2</a></div>		
	
	</nav><!-- #nav-below -->
	
					<div id="comments" class="comments-area">
	
	
	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Laisser un commentaire <small><a rel="nofollow" id="cancel-comment-reply-link" href="/?p=716#respond" style="display:none;">Annuler la réponse.</a></small></h3><p class="must-log-in">Vous devez <a href="https://www.miscmag.com/wp-login.php?redirect_to=https%3A%2F%2Fwww.miscmag.com%2F%3Fp%3D716">être connecté·e</a> pour rédiger un commentaire.</p>	</div><!-- #respond -->
	
</div><!-- #comments .comments-area -->

			
			</div><!-- #content -->
		</div><!-- #primary .site-content -->

		<div id="secondary" class="widget-area" role="complementary">
						<aside id="text-2" class="widget widget_text"><h1 class="widget-title">Suivez-nous !</h1>			<div class="textwidget"><a href="https://twitter.com/MISCRedac" class="twitter-follow-button" data-show-count="false" data-lang="fr" data-size="large">Suivre @MISCRedac</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script></div>
		</aside><aside id="widget_sp_image-2" class="widget widget_sp_image"><h1 class="widget-title">En kiosque !</h1><a href="https://boutique.ed-diamond.com/en-kiosque/1255-misc-92.html" target="_blank" class="widget_sp_image-image-link" title="En kiosque !"><img width="225" height="300" alt="En kiosque !" class="attachment-medium aligncenter" style="max-width: 100%;" srcset="https://www.miscmag.com/wp-content/uploads/2017/08/misc93-1-225x300.jpg 225w, https://www.miscmag.com/wp-content/uploads/2017/08/misc93-1-768x1024.jpg 768w, https://www.miscmag.com/wp-content/uploads/2017/08/misc93-1.jpg 794w" sizes="(max-width: 225px) 100vw, 225px" src="https://www.miscmag.com/wp-content/uploads/2017/08/misc93-1-225x300.jpg" /></a></aside><aside id="widget_sp_image-15" class="widget widget_sp_image"><a href="http://www.6cure.com/" target="_blank" class="widget_sp_image-image-link"><img width="416" height="347" class="attachment-full" style="max-width: 100%;" srcset="https://www.miscmag.com/wp-content/uploads/2017/04/Pavé_web_Misc_6cure.png 416w, https://www.miscmag.com/wp-content/uploads/2017/04/Pavé_web_Misc_6cure-300x250.png 300w" sizes="(max-width: 416px) 100vw, 416px" src="https://www.miscmag.com/wp-content/uploads/2017/04/Pavé_web_Misc_6cure.png" /></a></aside><aside id="widget_sp_image-9" class="widget widget_sp_image"><a href="https://proboutique.ed-diamond.com/abo-pro-basedoc" target="_blank" class="widget_sp_image-image-link"><img width="740" height="236" class="attachment-full" style="max-width: 100%;" srcset="https://www.miscmag.com/wp-content/uploads/2017/03/connect-boutonAbo-Pro.png 740w, https://www.miscmag.com/wp-content/uploads/2017/03/connect-boutonAbo-Pro-300x96.png 300w" sizes="(max-width: 740px) 100vw, 740px" src="https://www.miscmag.com/wp-content/uploads/2017/03/connect-boutonAbo-Pro.png" /></a></aside><aside id="widget_sp_image-13" class="widget widget_sp_image"><a href="https://boutique.ed-diamond.com/27-base-documentaire" target="_blank" class="widget_sp_image-image-link"><img width="740" height="236" class="attachment-full" style="max-width: 100%;" srcset="https://www.miscmag.com/wp-content/uploads/2017/03/connect-boutonAbo-Part.png 740w, https://www.miscmag.com/wp-content/uploads/2017/03/connect-boutonAbo-Part-300x96.png 300w" sizes="(max-width: 740px) 100vw, 740px" src="https://www.miscmag.com/wp-content/uploads/2017/03/connect-boutonAbo-Part.png" /></a></aside><aside id="widget_sp_image-14" class="widget widget_sp_image"><a href="http://www.formation-technologique.fr/manager-en-ingenierie-informatique-cybersecurite" target="_blank" class="widget_sp_image-image-link"><img width="300" height="251" class="attachment-medium aligncenter" style="max-width: 100%;" srcset="https://www.miscmag.com/wp-content/uploads/2017/04/M2i-banner-300x250-300x251.png 300w, https://www.miscmag.com/wp-content/uploads/2017/04/M2i-banner-300x250.png 400w" sizes="(max-width: 300px) 100vw, 300px" src="https://www.miscmag.com/wp-content/uploads/2017/04/M2i-banner-300x250-300x251.png" /></a></aside><aside id="widget_sp_image-7" class="widget widget_sp_image"><a href="http://www.hsc-formation.fr/" target="_blank" class="widget_sp_image-image-link"><img width="250" height="300" class="attachment-full aligncenter" style="max-width: 100%;" src="https://www.miscmag.com/wp-content/uploads/2017/03/unnamed.gif" /></a></aside>    
<!-- 
	Plugin: Custom Meta Widget	Plugin URL: http://shinraholdings.com/plugins/custom-meta-widget/-->


	<aside id="custommetawidget-2" class="widget customMetaWidget">	<h1 class="widget-title">Connexion</h1>	<ul>
	
	
    <li><a href="https://www.miscmag.com/wp-login.php?action=register">Inscription</a></li><li><a href="https://www.miscmag.com/wp-login.php">Connexion</a></li>	
	</ul>
    
	</aside><aside id="widget_sp_image-6" class="widget widget_sp_image"><a href="http://www.ikoula.com/" target="_blank" class="widget_sp_image-image-link"><img width="300" height="250" class="attachment-medium" style="max-width: 100%;" src="https://www.miscmag.com/wp-content/uploads/2015/01/300x250_gaulois.gif" /></a></aside><aside id="widget_sp_image-4" class="widget widget_sp_image"><h1 class="widget-title">Découvrez notre guide dédié à la sécurité des systèmes sans fil !</h1><a href="https://boutique.ed-diamond.com/en-kiosque/1274-misc-hs-16.html" target="_blank" class="widget_sp_image-image-link" title="Découvrez notre guide dédié à la sécurité des systèmes sans fil !"><img width="225" height="300" alt="Découvrez notre guide dédié à la sécurité des systèmes sans fil !" class="attachment-medium aligncenter" style="max-width: 100%;" srcset="https://www.miscmag.com/wp-content/uploads/2017/09/mischs16-1-225x300.jpg 225w, https://www.miscmag.com/wp-content/uploads/2017/09/mischs16-1.jpg 579w" sizes="(max-width: 225px) 100vw, 225px" src="https://www.miscmag.com/wp-content/uploads/2017/09/mischs16-1-225x300.jpg" /></a></aside><aside id="widget_sp_image-8" class="widget widget_sp_image"><a href="https://boutique.ed-diamond.com/" target="_blank" class="widget_sp_image-image-link"><img width="300" height="252" class="attachment-medium" style="max-width: 100%;" srcset="https://www.miscmag.com/wp-content/uploads/2017/01/pave-boutique-diamond-2017-300x252.jpg 300w, https://www.miscmag.com/wp-content/uploads/2017/01/pave-boutique-diamond-2017.jpg 620w" sizes="(max-width: 300px) 100vw, 300px" src="https://www.miscmag.com/wp-content/uploads/2017/01/pave-boutique-diamond-2017-300x252.jpg" /></a></aside><aside id="tag_cloud-2" class="widget widget_tag_cloud"><h1 class="widget-title">Mots-clés</h1><div class="tagcloud"><a href="https://www.miscmag.com/?tag=64-bit" class="tag-cloud-link tag-link-44 tag-link-position-1" style="font-size: 13.25pt;" aria-label="64 bit (2 éléments)">64 bit</a>
<a href="https://www.miscmag.com/?tag=apt" class="tag-cloud-link tag-link-11 tag-link-position-2" style="font-size: 13.25pt;" aria-label="APT (2 éléments)">APT</a>
<a href="https://www.miscmag.com/?tag=aslr" class="tag-cloud-link tag-link-43 tag-link-position-3" style="font-size: 13.25pt;" aria-label="ASLR (2 éléments)">ASLR</a>
<a href="https://www.miscmag.com/?tag=bgp" class="tag-cloud-link tag-link-38 tag-link-position-4" style="font-size: 13.25pt;" aria-label="BGP (2 éléments)">BGP</a>
<a href="https://www.miscmag.com/?tag=bitcoin" class="tag-cloud-link tag-link-15 tag-link-position-5" style="font-size: 8pt;" aria-label="bitcoin (1 élément)">bitcoin</a>
<a href="https://www.miscmag.com/?tag=cb" class="tag-cloud-link tag-link-14 tag-link-position-6" style="font-size: 8pt;" aria-label="CB (1 élément)">CB</a>
<a href="https://www.miscmag.com/?tag=chiffrement-de-bout-en-bout" class="tag-cloud-link tag-link-57 tag-link-position-7" style="font-size: 13.25pt;" aria-label="chiffrement de bout en bout (2 éléments)">chiffrement de bout en bout</a>
<a href="https://www.miscmag.com/?tag=cloud" class="tag-cloud-link tag-link-12 tag-link-position-8" style="font-size: 8pt;" aria-label="cloud (1 élément)">cloud</a>
<a href="https://www.miscmag.com/?tag=contacts" class="tag-cloud-link tag-link-58 tag-link-position-9" style="font-size: 13.25pt;" aria-label="contacts (2 éléments)">contacts</a>
<a href="https://www.miscmag.com/?tag=cryptographie" class="tag-cloud-link tag-link-26 tag-link-position-10" style="font-size: 19.666666666667pt;" aria-label="cryptographie (4 éléments)">cryptographie</a>
<a href="https://www.miscmag.com/?tag=decrypt-sh-x" class="tag-cloud-link tag-link-50 tag-link-position-11" style="font-size: 13.25pt;" aria-label="Decrypt SH.X (2 éléments)">Decrypt SH.X</a>
<a href="https://www.miscmag.com/?tag=double-ratchet" class="tag-cloud-link tag-link-76 tag-link-position-12" style="font-size: 13.25pt;" aria-label="Double Ratchet (2 éléments)">Double Ratchet</a>
<a href="https://www.miscmag.com/?tag=encrypt-sh" class="tag-cloud-link tag-link-49 tag-link-position-13" style="font-size: 13.25pt;" aria-label="Encrypt SH (2 éléments)">Encrypt SH</a>
<a href="https://www.miscmag.com/?tag=exploit" class="tag-cloud-link tag-link-41 tag-link-position-14" style="font-size: 19.666666666667pt;" aria-label="Exploit (4 éléments)">Exploit</a>
<a href="https://www.miscmag.com/?tag=federation" class="tag-cloud-link tag-link-74 tag-link-position-15" style="font-size: 13.25pt;" aria-label="Fédération (2 éléments)">Fédération</a>
<a href="https://www.miscmag.com/?tag=hijacking" class="tag-cloud-link tag-link-39 tag-link-position-16" style="font-size: 13.25pt;" aria-label="Hijacking (2 éléments)">Hijacking</a>
<a href="https://www.miscmag.com/?tag=hors-serie" class="tag-cloud-link tag-link-10 tag-link-position-17" style="font-size: 8pt;" aria-label="hors-série (1 élément)">hors-série</a>
<a href="https://www.miscmag.com/?tag=intrusion" class="tag-cloud-link tag-link-9 tag-link-position-18" style="font-size: 19.666666666667pt;" aria-label="intrusion (4 éléments)">intrusion</a>
<a href="https://www.miscmag.com/?tag=iot" class="tag-cloud-link tag-link-28 tag-link-position-19" style="font-size: 16.75pt;" aria-label="IoT (3 éléments)">IoT</a>
<a href="https://www.miscmag.com/?tag=java" class="tag-cloud-link tag-link-42 tag-link-position-20" style="font-size: 13.25pt;" aria-label="java (2 éléments)">java</a>
<a href="https://www.miscmag.com/?tag=man-in-the-middle" class="tag-cloud-link tag-link-59 tag-link-position-21" style="font-size: 13.25pt;" aria-label="Man In The Middle (2 éléments)">Man In The Middle</a>
<a href="https://www.miscmag.com/?tag=messageries-securisees" class="tag-cloud-link tag-link-56 tag-link-position-22" style="font-size: 13.25pt;" aria-label="messageries sécurisées (2 éléments)">messageries sécurisées</a>
<a href="https://www.miscmag.com/?tag=metasploit" class="tag-cloud-link tag-link-30 tag-link-position-23" style="font-size: 13.25pt;" aria-label="metasploit (2 éléments)">metasploit</a>
<a href="https://www.miscmag.com/?tag=mobile" class="tag-cloud-link tag-link-55 tag-link-position-24" style="font-size: 13.25pt;" aria-label="Mobile (2 éléments)">Mobile</a>
<a href="https://www.miscmag.com/?tag=obfuscation" class="tag-cloud-link tag-link-23 tag-link-position-25" style="font-size: 13.25pt;" aria-label="obfuscation (2 éléments)">obfuscation</a>
<a href="https://www.miscmag.com/?tag=omemo" class="tag-cloud-link tag-link-72 tag-link-position-26" style="font-size: 13.25pt;" aria-label="OMEMO (2 éléments)">OMEMO</a>
<a href="https://www.miscmag.com/?tag=paiement" class="tag-cloud-link tag-link-13 tag-link-position-27" style="font-size: 8pt;" aria-label="paiement (1 élément)">paiement</a>
<a href="https://www.miscmag.com/?tag=partenariat" class="tag-cloud-link tag-link-8 tag-link-position-28" style="font-size: 8pt;" aria-label="partenariat (1 élément)">partenariat</a>
<a href="https://www.miscmag.com/?tag=pentest" class="tag-cloud-link tag-link-53 tag-link-position-29" style="font-size: 19.666666666667pt;" aria-label="Pentest (4 éléments)">Pentest</a>
<a href="https://www.miscmag.com/?tag=reverse-sh-x" class="tag-cloud-link tag-link-51 tag-link-position-30" style="font-size: 13.25pt;" aria-label="Reverse SH.X (2 éléments)">Reverse SH.X</a>
<a href="https://www.miscmag.com/?tag=rop" class="tag-cloud-link tag-link-45 tag-link-position-31" style="font-size: 13.25pt;" aria-label="ROP (2 éléments)">ROP</a>
<a href="https://www.miscmag.com/?tag=reseau" class="tag-cloud-link tag-link-25 tag-link-position-32" style="font-size: 16.75pt;" aria-label="réseau (3 éléments)">réseau</a>
<a href="https://www.miscmag.com/?tag=shc" class="tag-cloud-link tag-link-46 tag-link-position-33" style="font-size: 13.25pt;" aria-label="SHC (2 éléments)">SHC</a>
<a href="https://www.miscmag.com/?tag=shell-compiler" class="tag-cloud-link tag-link-48 tag-link-position-34" style="font-size: 13.25pt;" aria-label="Shell Compiler (2 éléments)">Shell Compiler</a>
<a href="https://www.miscmag.com/?tag=signal" class="tag-cloud-link tag-link-71 tag-link-position-35" style="font-size: 13.25pt;" aria-label="signal (2 éléments)">signal</a>
<a href="https://www.miscmag.com/?tag=spam" class="tag-cloud-link tag-link-37 tag-link-position-36" style="font-size: 13.25pt;" aria-label="spam (2 éléments)">spam</a>
<a href="https://www.miscmag.com/?tag=securite" class="tag-cloud-link tag-link-17 tag-link-position-37" style="font-size: 13.25pt;" aria-label="sécurité (2 éléments)">sécurité</a>
<a href="https://www.miscmag.com/?tag=unshc" class="tag-cloud-link tag-link-47 tag-link-position-38" style="font-size: 13.25pt;" aria-label="UNSHC (2 éléments)">UNSHC</a>
<a href="https://www.miscmag.com/?tag=usurpation" class="tag-cloud-link tag-link-40 tag-link-position-39" style="font-size: 13.25pt;" aria-label="Usurpation (2 éléments)">Usurpation</a>
<a href="https://www.miscmag.com/?tag=web" class="tag-cloud-link tag-link-31 tag-link-position-40" style="font-size: 13.25pt;" aria-label="web (2 éléments)">web</a>
<a href="https://www.miscmag.com/?tag=whatsapp" class="tag-cloud-link tag-link-73 tag-link-position-41" style="font-size: 13.25pt;" aria-label="Whatsapp (2 éléments)">Whatsapp</a>
<a href="https://www.miscmag.com/?tag=windows" class="tag-cloud-link tag-link-19 tag-link-position-42" style="font-size: 22pt;" aria-label="windows (5 éléments)">windows</a>
<a href="https://www.miscmag.com/?tag=x3dh" class="tag-cloud-link tag-link-75 tag-link-position-43" style="font-size: 13.25pt;" aria-label="X3DH (2 éléments)">X3DH</a>
<a href="https://www.miscmag.com/?tag=xmpp" class="tag-cloud-link tag-link-70 tag-link-position-44" style="font-size: 13.25pt;" aria-label="XMPP (2 éléments)">XMPP</a>
<a href="https://www.miscmag.com/?tag=elevation-de-privileges" class="tag-cloud-link tag-link-54 tag-link-position-45" style="font-size: 19.666666666667pt;" aria-label="élévation de privilèges (4 éléments)">élévation de privilèges</a></div>
</aside><aside id="search-2" class="widget widget_search"><h1 class="widget-title">Rechercher</h1>	<form method="get" id="searchform" action="https://www.miscmag.com/" role="search">
		<label for="s" class="assistive-text">Rechercher</label>
		<input type="text" class="field" name="s" id="s" placeholder="Rechercher &hellip;" />
		<input type="submit" class="submit" name="submit" id="searchsubmit" value="Rechercher" />
	</form>
</aside>		</div><!-- #secondary .widget-area -->

	</div><!-- #main -->

	<footer id="colophon" class="site-footer" role="contentinfo">
		
		
				<nav role="navigation" class="footer-navigation">
			<div class="menu-menu-bas-de-page-container"><ul id="menu-menu-bas-de-page" class="menu"><li id="menu-item-28" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28"><a target="_blank" href="http://boutique.ed-diamond.com/">BOUTIQUE</a></li>
<li id="menu-item-29" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29"><a target="_blank" href="http://www.editions-diamond.fr/index.php/magazines/annonceur">ANNONCEURS</a></li>
<li id="menu-item-270" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-270"><a href="http://www.editions-diamond.fr/devenir-auteur/">CONTRIBUER</a></li>
<li id="menu-item-27" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27"><a href="https://www.miscmag.com/?page_id=9">À PROPOS</a></li>
</ul></div>		</nav>
				
		<div class="site-info">

						
			2017 Le blog de MISC <span class="sep">-</span> Propulsé par  <a href="http://wordpress.org/" title="Plate-forme de publication personnelle sémantique de pointe">WordPress</a> <span class="sep">-</span> Thème Mon Cahier par <a href="http://bluelimemedia.com/" title="Bluelime Media">Bluelime Media</a>
			

		</div><!-- .site-info -->
	</footer><!-- .site-footer .site-footer -->
</div><!-- #page .hfeed .site -->

<script type='text/javascript' src='https://www.miscmag.com/wp-content/themes/mon-cahierMISC/js/small-menu.js?ver=20120206'></script>
<script type='text/javascript' src='https://www.miscmag.com/wp-includes/js/comment-reply.min.js?ver=4.8.2'></script>
<script type='text/javascript' src='https://www.miscmag.com/wp-content/plugins/dvk-social-sharing/assets/js/script.min.js?ver=1.3'></script>
<script type='text/javascript' src='https://www.miscmag.com/wp-includes/js/wp-embed.min.js?ver=4.8.2'></script>
<script type='text/javascript' src='https://www.miscmag.com/wp-content/plugins/easy-fancybox/fancybox/jquery.fancybox-1.3.8.min.js?ver=1.6'></script>
<script type='text/javascript' src='https://www.miscmag.com/wp-content/plugins/easy-fancybox/js/jquery.easing.min.js?ver=1.4.0'></script>
<script type='text/javascript' src='https://www.miscmag.com/wp-content/plugins/easy-fancybox/js/jquery.mousewheel.min.js?ver=3.1.13'></script>
<script type="text/javascript">
jQuery(document).on('ready post-load', function(){ jQuery('.nofancybox,a.pin-it-button,a[href*="pinterest.com/pin/create/button"]').addClass('nolightbox'); });
jQuery(document).on('ready post-load',easy_fancybox_handler);
jQuery(document).on('ready',easy_fancybox_auto);</script>
<!-- Générer en 1,979 secondes. Faites 37 les requêtes de base de données et 75 les requêtes de la mémoire cache. Mémoire utilisée - 29.71MB -->
<!-- Cached by DB Cache Reloaded Fix -->
</body>
</html>